aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/version.mk2
-rw-r--r--package/base-files/image-config.in8
2 files changed, 5 insertions, 5 deletions
diff --git a/include/version.mk b/include/version.mk
index a21bf25c7f..1a0d3c990b 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -31,7 +31,7 @@ qstrip_escape=$(subst ','\'',$(call qstrip,$(1)))
sanitize = $(call tolower,$(subst _,-,$(subst $(space),-,$(1))))
VERSION_NUMBER:=$(call qstrip_escape,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),CURRENT)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),SNAPSHOT)
VERSION_CODE:=$(call qstrip_escape,$(CONFIG_VERSION_CODE))
VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),$(REVISION))
diff --git a/package/base-files/image-config.in b/package/base-files/image-config.in
index b18f2d85b1..a8d82d3e0c 100644
--- a/package/base-files/image-config.in
+++ b/package/base-files/image-config.in
@@ -175,8 +175,8 @@ if VERSIONOPT
prompt "Release version number"
help
This is the release version number embedded in the image.
- If unspecified, it defaults to CURRENT for the master branch
- or to ##.##-CURRENT on release branches.
+ If unspecified, it defaults to SNAPSHOT for the master branch
+ or to ##.##-SNAPSHOT on release branches.
config VERSION_CODE
string
@@ -195,8 +195,8 @@ if VERSIONOPT
This is the repository address embedded in the image, it defaults
to the trunk snapshot repo; the url may contain the following placeholders:
%R .. Repository revision ID
- %V .. Configured release version number or "CURRENT", uppercase
- %v .. Configured release version number or "current", lowercase
+ %V .. Configured release version number or "SNAPSHOT", uppercase
+ %v .. Configured release version number or "snapshot", lowercase
%C .. Configured release revision code or value of %R, uppercase
%c .. Configured release revision code or value of %R, lowercase
%N .. Release name, uppercase