aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image-commands.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 5f0ac6164d..bcc1256df8 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -229,6 +229,19 @@ define Build/combined-image
@mv $@.new $@
endef
+define Build/openmesh-image
+ $(TOPDIR)/scripts/om-fwupgradecfg-gen.sh \
+ "$(call param_get_default,ce_type,$(1),$(DEVICE_NAME))" \
+ "$@-fwupgrade.cfg" \
+ "$(call param_get_default,kernel,$(1),$(IMAGE_KERNEL))" \
+ "$(call param_get_default,rootfs,$(1),$@)"
+ $(TOPDIR)/scripts/combined-ext-image.sh \
+ "$(call param_get_default,ce_type,$(1),$(DEVICE_NAME))" "$@" \
+ "$@-fwupgrade.cfg" "fwupgrade.cfg" \
+ "$(call param_get_default,kernel,$(1),$(IMAGE_KERNEL))" "kernel" \
+ "$(call param_get_default,rootfs,$(1),$@)" "rootfs"
+endef
+
define Build/sysupgrade-tar
sh $(TOPDIR)/scripts/sysupgrade-tar.sh \
--board $(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)) \