aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/system/ubox/Makefile2
-rw-r--r--package/system/ubox/files/log.init2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index 89cc6768fb..85dddff858 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubox
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/ubox.git
diff --git a/package/system/ubox/files/log.init b/package/system/ubox/files/log.init
index 21e0787125..ae5dd1f03d 100644
--- a/package/system/ubox/files/log.init
+++ b/package/system/ubox/files/log.init
@@ -55,6 +55,8 @@ start_service_file()
}
[ -z "${log_file}" ] && return
+ mkdir -p "$(dirname "${log_file}")"
+
procd_open_instance
procd_set_param command "$PROG" -f -F "$log_file" -p "$pid_file"
[ -n "${log_size}" ] && procd_append_param command -S "$log_size"