aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/image.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index a6ea8e5452..fd5e3f4b62 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -384,7 +384,8 @@ define Build/append-ubi
$(if $(KERNEL_IN_UBI),--kernel $(word 1,$^)) \
$(word 2,$^) \
$@.tmp \
- -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5
+ -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5 \
+ $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE))
cat $@.tmp >> $@
rm $@.tmp
endef