aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ramips/image/mt7620.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 42745c4109..e27c405b3c 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -37,7 +37,9 @@ define Device/ArcherC20i
SUPPORTED_DEVICES := c20i
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC20i -c
+ IMAGE/factory.bin := append-kernel | tplink-header ArcherC20i -j
IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC20i -j | append-metadata
+ IMAGES += factory.bin
DEVICE_TITLE := TP-Link ArcherC20i
endef
TARGET_DEVICES += ArcherC20i
@@ -47,7 +49,9 @@ define Device/ArcherC50
SUPPORTED_DEVICES := c50
KERNEL := $(KERNEL_DTB)
KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherC50 -c
+ IMAGE/factory.bin := append-kernel | tplink-header ArcherC50 -j
IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherC50 -j | append-metadata
+ IMAGES += factory.bin
DEVICE_TITLE := TP-Link ArcherC50
endef
TARGET_DEVICES += ArcherC50