aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-images.in8
-rw-r--r--target/linux/x86/image/Makefile3
-rw-r--r--target/linux/x86/image/grub-iso.cfg2
-rw-r--r--target/linux/x86/image/grub.cfg4
4 files changed, 14 insertions, 3 deletions
diff --git a/config/Config-images.in b/config/Config-images.in
index 07ef619e70..76e64641b4 100644
--- a/config/Config-images.in
+++ b/config/Config-images.in
@@ -231,6 +231,14 @@ menu "Target Images"
help
If you don't know, 5 seconds is a reasonable default.
+ config GRUB_TITLE
+ string "Title for the menu entry in GRUB"
+ depends on GRUB_IMAGES
+ default "OpenWrt"
+ help
+ This is the title of the GRUB menu entry.
+ If unspecified, it defaults to OpenWrt.
+
config VDI_IMAGES
bool "Build VirtualBox image files (VDI)"
depends on TARGET_x86 || TARGET_x86_64
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 8a3cb327e3..b537c40f24 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -46,6 +46,7 @@ ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
ROOTPART:=$(if $(ROOTPART),$(ROOTPART),PARTUUID=$(SIGNATURE)-02)
GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_GRUB_TIMEOUT))
+GRUB_TITLE:=$(call qstrip,$(CONFIG_GRUB_TITLE))
ifneq ($(CONFIG_TARGET_x86_xen_domu),)
GRUB_ROOT = xen/xvda,msdos1
@@ -82,6 +83,7 @@ ifneq ($(CONFIG_GRUB_IMAGES),)
-e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
-e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
-e 's#@ROOT@#$(GRUB_ROOT)#g' \
+ -e 's#@TITLE@#$(GRUB_TITLE)#g' \
./grub.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
PADDING="$(CONFIG_TARGET_IMAGES_PAD)" SIGNATURE="$(SIGNATURE)" PATH="$(TARGET_PATH)" $(SCRIPT_DIR)/gen_image_generic.sh \
$(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
@@ -119,6 +121,7 @@ define Image/Build/iso
-e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
-e 's#@CMDLINE@#root=/dev/sr0 rootfstype=iso9660 rootwait $(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
-e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
+ -e 's#@TITLE@#$(GRUB_TITLE)#g' \
./grub-iso.cfg > $(KDIR)/root.grub/boot/grub/grub.cfg
mkisofs -R -b boot/grub/eltorito.img -no-emul-boot -boot-info-table \
-o $(KDIR)/root.iso $(KDIR)/root.grub $(TARGET_DIR)
diff --git a/target/linux/x86/image/grub-iso.cfg b/target/linux/x86/image/grub-iso.cfg
index 3d47a95a4b..9c59bdf6d4 100644
--- a/target/linux/x86/image/grub-iso.cfg
+++ b/target/linux/x86/image/grub-iso.cfg
@@ -5,6 +5,6 @@ set default="0"
set timeout="@TIMEOUT@"
set root='(cd)'
-menuentry "OpenWrt" {
+menuentry "@TITLE@" {
linux /boot/vmlinuz @CMDLINE@ noinitrd
}
diff --git a/target/linux/x86/image/grub.cfg b/target/linux/x86/image/grub.cfg
index 9ec6b2d39c..dedfa0a636 100644
--- a/target/linux/x86/image/grub.cfg
+++ b/target/linux/x86/image/grub.cfg
@@ -5,9 +5,9 @@ set default="0"
set timeout="@TIMEOUT@"
set root='(@ROOT@)'
-menuentry "OpenWrt" {
+menuentry "@TITLE@" {
linux /boot/vmlinuz @CMDLINE@ noinitrd
}
-menuentry "OpenWrt (failsafe)" {
+menuentry "@TITLE@ (failsafe)" {
linux /boot/vmlinuz failsafe=true @CMDLINE@ noinitrd
}