aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/autotools.mk13
-rw-r--r--tools/libtool/Makefile2
2 files changed, 0 insertions, 15 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index cba36ccd9f..c378efe6f9 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -124,13 +124,6 @@ ifneq ($(filter libtool-abiver,$(PKG_FIXUP)),)
Hooks/Configure/Post += set_libtool_abiver
endif
-ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
- PKG_BUILD_DEPENDS += libtool
- ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
- Hooks/Configure/Pre += autoreconf_target
- endif
-endif
-
ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
ifeq ($(filter autoreconf,$(Hooks/Configure/Pre)),)
Hooks/Configure/Pre += autoreconf_target
@@ -166,12 +159,6 @@ ifneq ($(filter libtool,$(HOST_FIXUP)),)
endif
endif
-ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
- ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
- Hooks/HostConfigure/Pre += autoreconf_host
- endif
-endif
-
ifneq ($(filter autoreconf,$(HOST_FIXUP)),)
ifeq ($(filter autoreconf,$(Hooks/HostConfigure/Pre)),)
Hooks/HostConfigure/Pre += autoreconf_host
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
index 6626142294..cc9e8a68fb 100644
--- a/tools/libtool/Makefile
+++ b/tools/libtool/Makefile
@@ -35,8 +35,6 @@ endef
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
$(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(STAGING_DIR_HOST)/bin/libtool
- $(CP) $(STAGING_DIR_HOST)/bin/libtool $(STAGING_DIR_HOST)/bin/libtool-ucxx
- $(SED) 's,-lstdc++,-luClibc++,g' $(STAGING_DIR_HOST)/bin/libtool-ucxx
endef
define Host/Uninstall