aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tools/quilt/patches/100-patch_2.6.1_version.patch8
1 files changed, 6 insertions, 2 deletions
diff --git a/tools/quilt/patches/100-patch_2.6.1_version.patch b/tools/quilt/patches/100-patch_2.6.1_version.patch
index 84f275318c..1e9ed75df1 100644
--- a/tools/quilt/patches/100-patch_2.6.1_version.patch
+++ b/tools/quilt/patches/100-patch_2.6.1_version.patch
@@ -1,11 +1,15 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -274,7 +274,7 @@ fi
+@@ -274,7 +274,11 @@ fi
AC_MSG_CHECKING([the version of $PATCH])
if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
set -- `$PATCH --version 2> /dev/null`
- patch_version=$2
-+ test $2 == "patch" && patch_version=$3 || patch_version=$2
++ if test x$1 = xGNU ; then
++ patch_version=$3
++ else
++ patch_version=$2
++ fi
AC_MSG_RESULT($patch_version)
saved_IFS=$IFS; IFS='.'
set -- $patch_version