aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--rules.mk3
2 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index db79274c9a..31042b2e09 100644
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,8 @@ ifneq ($(OPENWRT_BUILD),1)
override OPENWRT_BUILD=1
export OPENWRT_BUILD
+ GREP_OPTIONS=
+ export GREP_OPTIONS
include $(TOPDIR)/include/debug.mk
include $(TOPDIR)/include/depends.mk
include $(TOPDIR)/include/toplevel.mk
diff --git a/rules.mk b/rules.mk
index 0cb72ac6bc..2add087133 100644
--- a/rules.mk
+++ b/rules.mk
@@ -18,6 +18,9 @@ TMP_DIR:=$(TOPDIR)/tmp
export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
+GREP_OPTIONS=
+export GREP_OPTIONS
+
qstrip=$(strip $(subst ",,$(1)))
#"))