aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/subdir.mk4
-rw-r--r--toolchain/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/include/subdir.mk b/include/subdir.mk
index d93d40fca7..3c1e3f9cae 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -47,9 +47,9 @@ define subdir
$(foreach target,$(SUBTARGETS),$(call subtarget,$(1),$(target)))
endef
-# Parameters: <subdir> <name> <target> <depends> <config options>
+# Parameters: <subdir> <name> <target> <depends> <config options> <stampfile location>
define stampfile
- $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
+ $(1)/stamp-$(3):=$(if $(6),$(6),$(STAGING_DIR))/stamp/.$(2)_$(3)$(if $(5),_$(call confvar,$(5)))
$$($(1)/stamp-$(3)): $(TMP_DIR)/.build $(4)
@+$(SCRIPT_DIR)/timestamp.pl -n $$($(1)/stamp-$(3)) $(1) $(4) || \
$(MAKE) $$($(1)/flags-$(3)) $(1)/$(3)
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 7762593ef6..61a74b8d1d 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -66,6 +66,6 @@ $(curdir)//install = $(1)/compile
$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
-$(eval $(call stampfile,$(curdir),toolchain,install,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed))
+$(eval $(call stampfile,$(curdir),toolchain,install,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed,,$(TOOLCHAIN_DIR)))
$(eval $(call subdir,$(curdir)))