aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_tplink_vr200.dtsi21
-rw-r--r--target/linux/lantiq/image/tp-link.mk4
2 files changed, 22 insertions, 3 deletions
diff --git a/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_tplink_vr200.dtsi b/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_tplink_vr200.dtsi
index 93178da7e2..77b4f0defb 100644
--- a/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_tplink_vr200.dtsi
+++ b/target/linux/lantiq/files/arch/mips/boot/dts/lantiq/vr9_tplink_vr200.dtsi
@@ -112,6 +112,25 @@
};
};
+&pcie0 {
+ pcie@0 {
+ reg = <0 0 0 0 0>;
+ #interrupt-cells = <1>;
+ #size-cells = <2>;
+ #address-cells = <3>;
+ device_type = "pci";
+
+ wifi@0,0 {
+ reg = <0 0 0 0 0>;
+ mediatek,mtd-eeprom = <&radio 0x0000>;
+ big-endian;
+ ieee80211-freq-limit = <5000000 6000000>;
+ mtd-mac-address = <&romfile 0xf100>;
+ mtd-mac-address-increment = <2>;
+ };
+ };
+};
+
&pci0 {
status = "okay";
gpio-reset = <&gpio 21 GPIO_ACTIVE_HIGH>;
@@ -166,7 +185,7 @@
read-only;
};
- partition@ff0000 {
+ radio: partition@ff0000 {
reg = <0xff0000 0x10000>;
label = "radio";
read-only;
diff --git a/target/linux/lantiq/image/tp-link.mk b/target/linux/lantiq/image/tp-link.mk
index 56a7e5ca57..fa98f31f59 100644
--- a/target/linux/lantiq/image/tp-link.mk
+++ b/target/linux/lantiq/image/tp-link.mk
@@ -47,7 +47,7 @@ define Device/tplink_vr200
TPLINK_HWID := 0x63e64801
TPLINK_HWREV := 0x53
IMAGE_SIZE := 15808k
- DEVICE_PACKAGES:= kmod-usb-dwc2 kmod-usb-ledtrig-usbport
+ DEVICE_PACKAGES:= kmod-mt76x0e wpad-basic kmod-usb-dwc2 kmod-usb-ledtrig-usbport
SUPPORTED_DEVICES += VR200
endef
TARGET_DEVICES += tplink_vr200
@@ -60,7 +60,7 @@ define Device/tplink_vr200v
TPLINK_HWID := 0x73b70801
TPLINK_HWREV := 0x2f
IMAGE_SIZE := 15808k
- DEVICE_PACKAGES:= kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-ltq-tapi kmod-ltq-vmmc
+ DEVICE_PACKAGES:= kmod-mt76x0e wpad-basic kmod-usb-dwc2 kmod-usb-ledtrig-usbport kmod-ltq-tapi kmod-ltq-vmmc
SUPPORTED_DEVICES += VR200v
endef
TARGET_DEVICES += tplink_vr200v