aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/spi.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/spi.mk b/package/kernel/linux/modules/spi.mk
index 416209825f..435fd74b11 100644
--- a/package/kernel/linux/modules/spi.mk
+++ b/package/kernel/linux/modules/spi.mk
@@ -14,8 +14,10 @@ define KernelPackage/mmc-spi
KCONFIG:=CONFIG_MMC_SPI \
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y
- FILES:=$(LINUX_DIR)/drivers/mmc/host/mmc_spi.ko
- AUTOLOAD:=$(call AutoLoad,90,mmc_spi)
+ FILES:=\
+ $(if $(CONFIG_OF),$(LINUX_DIR)/drivers/mmc/host/of_mmc_spi.ko) \
+ $(LINUX_DIR)/drivers/mmc/host/mmc_spi.ko
+ AUTOLOAD:=$(call AutoLoad,90,$(if $(CONFIG_OF),of_mmc_spi) mmc_spi)
endef
define KernelPackage/mmc-spi/description