aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/netfilter.mk4
-rw-r--r--package/kernel/linux/modules/netsupport.mk66
-rw-r--r--target/linux/mcs814x/config-3.181
-rw-r--r--target/linux/xburst/config-3.181
4 files changed, 2 insertions, 70 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index a5941d2310..6162dbc362 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -669,7 +669,7 @@ define KernelPackage/br-netfilter
SUBMENU:=$(NF_MENU)
TITLE:=Bridge netfilter support modules
HIDDEN:=1
- DEPENDS:=+kmod-ipt-core +kmod-bridge
+ DEPENDS:=+kmod-ipt-core
FILES:=$(LINUX_DIR)/net/bridge/br_netfilter.ko
KCONFIG:=CONFIG_BRIDGE_NETFILTER
AUTOLOAD:=$(call AutoProbe,br_netfilter)
@@ -681,7 +681,7 @@ $(eval $(call KernelPackage,br-netfilter))
define KernelPackage/ebtables
SUBMENU:=$(NF_MENU)
TITLE:=Bridge firewalling modules
- DEPENDS:=+kmod-ipt-core +kmod-bridge +kmod-br-netfilter
+ DEPENDS:=+kmod-ipt-core +kmod-br-netfilter
FILES:=$(foreach mod,$(EBTABLES-m),$(LINUX_DIR)/net/$(mod).ko)
KCONFIG:=$(KCONFIG_EBTABLES)
AUTOLOAD:=$(call AutoProbe,$(notdir $(EBTABLES-m)))
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index bed0828634..dc6e0cbfe0 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -45,7 +45,6 @@ $(eval $(call KernelPackage,atmtcp))
define KernelPackage/appletalk
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Appletalk protocol support
- DEPENDS:=+PACKAGE_kmod-llc:kmod-llc
KCONFIG:= \
CONFIG_ATALK \
CONFIG_DEV_APPLETALK \
@@ -80,71 +79,6 @@ endef
$(eval $(call KernelPackage,bonding))
-define KernelPackage/bridge
- SUBMENU:=$(NETWORK_SUPPORT_MENU)
- TITLE:=Ethernet bridging support
- DEPENDS:=+kmod-stp
- KCONFIG:= \
- CONFIG_BRIDGE \
- CONFIG_BRIDGE_IGMP_SNOOPING=y
- FILES:=$(LINUX_DIR)/net/bridge/bridge.ko
- AUTOLOAD:=$(call AutoLoad,11,bridge)
-endef
-
-define KernelPackage/bridge/description
- Kernel module for Ethernet bridging.
-endef
-
-$(eval $(call KernelPackage,bridge))
-
-define KernelPackage/llc
- SUBMENU:=$(NETWORK_SUPPORT_MENU)
- TITLE:=ANSI/IEEE 802.2 LLC support
- KCONFIG:=CONFIG_LLC
- FILES:= \
- $(LINUX_DIR)/net/llc/llc.ko \
- $(LINUX_DIR)/net/802/p8022.ko \
- $(LINUX_DIR)/net/802/psnap.ko
- AUTOLOAD:=$(call AutoLoad,09,llc p8022 psnap)
-endef
-
-define KernelPackage/llc/description
- Kernel module for ANSI/IEEE 802.2 LLC support.
-endef
-
-$(eval $(call KernelPackage,llc))
-
-define KernelPackage/stp
- SUBMENU:=$(NETWORK_SUPPORT_MENU)
- TITLE:=Ethernet Spanning Tree Protocol support
- DEPENDS:=+kmod-llc
- KCONFIG:=CONFIG_STP
- FILES:=$(LINUX_DIR)/net/802/stp.ko
- AUTOLOAD:=$(call AutoLoad,10,stp)
-endef
-
-define KernelPackage/stp/description
- Kernel module for Ethernet Spanning Tree Protocol support.
-endef
-
-$(eval $(call KernelPackage,stp))
-
-define KernelPackage/8021q
- SUBMENU:=$(NETWORK_SUPPORT_MENU)
- TITLE:=802.1Q VLAN support
- KCONFIG:=CONFIG_VLAN_8021Q \
- CONFIG_VLAN_8021Q_GVRP=n
- FILES:=$(LINUX_DIR)/net/8021q/8021q.ko
- AUTOLOAD:=$(call AutoLoad,12,8021q)
-endef
-
-define KernelPackage/8021q/description
- Kernel module for 802.1Q VLAN support
-endef
-
-$(eval $(call KernelPackage,8021q))
-
-
define KernelPackage/udptunnel4
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=IPv4 UDP tunneling support
diff --git a/target/linux/mcs814x/config-3.18 b/target/linux/mcs814x/config-3.18
index 427a7c92ce..7f1c5705fd 100644
--- a/target/linux/mcs814x/config-3.18
+++ b/target/linux/mcs814x/config-3.18
@@ -220,7 +220,6 @@ CONFIG_USB_SUPPORT=y
CONFIG_USE_OF=y
CONFIG_VECTORS_BASE=0xffff0000
# CONFIG_VFP is not set
-# CONFIG_VLAN_8021Q is not set
CONFIG_VM_EVENT_COUNTERS=y
CONFIG_WATCHDOG_CORE=y
CONFIG_WATCHDOG_NOWAYOUT=y
diff --git a/target/linux/xburst/config-3.18 b/target/linux/xburst/config-3.18
index 71411bf067..81e7eddbdf 100644
--- a/target/linux/xburst/config-3.18
+++ b/target/linux/xburst/config-3.18
@@ -341,7 +341,6 @@ CONFIG_USB_SUPPORT=y
CONFIG_USB_U_ETHER=y
CONFIG_VFAT_FS=y
# CONFIG_VGA_CONSOLE is not set
-# CONFIG_VLAN_8021Q is not set
CONFIG_VT=y
CONFIG_VT_CONSOLE=y
CONFIG_VT_CONSOLE_SLEEP=y