aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/lib/fw.sh16
2 files changed, 2 insertions, 16 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 597a37e140..749f04a4b1 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=35
+PKG_RELEASE:=36
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/lib/fw.sh b/package/firewall/files/lib/fw.sh
index a13eb7eb13..bf7156e8ce 100644
--- a/package/firewall/files/lib/fw.sh
+++ b/package/firewall/files/lib/fw.sh
@@ -74,21 +74,7 @@ fw__exec() { # <action> <family> <table> <chain> <target> <position> { <rules> }
fw__rc $(($? & 1))
return
fi
- local mod
- eval "mod=\$FW_${fam#G}_${tab}"
- if [ "$mod" ]; then
- fw__rc $mod
- return
- fi
- case "$fam" in
- *4) mod=iptable_${tab} ;;
- *6) mod=ip6table_${tab} ;;
- *) mod=. ;;
- esac
- grep -q "^${mod} " /proc/modules
- mod=$?
- export FW_${fam}_${tab}=$mod
- fw__rc $mod
+ fw__rc 0
}
fw__err() {