aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--README.md2
-rw-r--r--include/prereq-build.mk4
2 files changed, 3 insertions, 3 deletions
diff --git a/README.md b/README.md
index 21acbf4b80..b30819205b 100644
--- a/README.md
+++ b/README.md
@@ -25,7 +25,7 @@ the [Build System Setup](https://openwrt.org/docs/guide-developer/build-system/i
documentation.
```
-gcc binutils bzip2 flex python3 perl make find grep diff unzip gawk getopt
+gcc binutils bzip2 flex python3 perl make4.1+ find grep diff unzip gawk getopt
subversion libz-dev libc-dev rsync
```
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 6dce11cba2..f88e853b52 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -11,8 +11,8 @@ PKG_NAME:=Build dependency
# Required for the toolchain
$(eval $(call TestHostCommand,working-make, \
- Please install GNU make v3.82 or later. (This version has bugs), \
- $(MAKE) -v | grep -E 'Make (3\.8[2-9]|3\.9[0-9]|[4-9]\.)'))
+ Please install GNU make v4.1 or later., \
+ $(MAKE) -v | grep -E 'Make (4\.[1-9]|[5-9]\.)'))
$(eval $(call TestHostCommand,case-sensitive-fs, \
OpenWrt can only be built on a case-sensitive filesystem, \