aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/boot/uboot-rockchip/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/boot/uboot-rockchip/Makefile b/package/boot/uboot-rockchip/Makefile
index d460e3723e..944c942efc 100644
--- a/package/boot/uboot-rockchip/Makefile
+++ b/package/boot/uboot-rockchip/Makefile
@@ -38,6 +38,16 @@ endef
# RK3399 boards
+define U-Boot/rock-pi-4-rk3399
+ BUILD_SUBTARGET:=armv8
+ NAME:=Rock Pi 4
+ BUILD_DEVICES:= \
+ radxa_rock-pi-4
+ DEPENDS:=+PACKAGE_u-boot-rock-pi-4-rk3399:arm-trusted-firmware-rockchip
+ PKG_BUILD_DEPENDS:=arm-trusted-firmware-rockchip
+ ATF:=rk3399_bl31.elf
+endef
+
define U-Boot/rockpro64-rk3399
BUILD_SUBTARGET:=armv8
NAME:=RockPro64
@@ -49,6 +59,7 @@ define U-Boot/rockpro64-rk3399
endef
UBOOT_TARGETS := \
+ rock-pi-4-rk3399 \
rockpro64-rk3399 \
nanopi-r2s-rk3328