aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm2708/patches-4.19/950-0642-drm-modes-Support-modes-names-on-the-command-line.patch2
-rw-r--r--target/linux/brcm2708/patches-4.19/950-0643-drm-modes-Allow-to-specify-rotation-and-reflection-o.patch4
-rw-r--r--target/linux/brcm2708/patches-4.19/950-0649-drm-modes-Don-t-apply-cmdline-s-rotation-if-it-wasn-.patch2
4 files changed, 6 insertions, 6 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 577946a087..63a6503cf5 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
endif
LINUX_VERSION-4.14 = .165
-LINUX_VERSION-4.19 = .95
+LINUX_VERSION-4.19 = .96
LINUX_KERNEL_HASH-4.14.165 = b0aeb52386404f4e3546f93cf63c857025fc3117ff1b56e3499aa1eae6e088c7
-LINUX_KERNEL_HASH-4.19.95 = 4aedca32eec13ac5103fc23e141f9221dfe120d1c0651c0a2efe7de2182f4fb0
+LINUX_KERNEL_HASH-4.19.96 = 23c1d1d5ba7bc14f9850e5ce78006712fe6c65dedcf67d3c99cec9c16a631d4d
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
diff --git a/target/linux/brcm2708/patches-4.19/950-0642-drm-modes-Support-modes-names-on-the-command-line.patch b/target/linux/brcm2708/patches-4.19/950-0642-drm-modes-Support-modes-names-on-the-command-line.patch
index aee684a955..1cacab25e2 100644
--- a/target/linux/brcm2708/patches-4.19/950-0642-drm-modes-Support-modes-names-on-the-command-line.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0642-drm-modes-Support-modes-names-on-the-command-line.patch
@@ -45,7 +45,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/18443e0c3bdbbd16cea4ec63bc7f
mode->rb ? " reduced blanking" : "",
--- a/drivers/gpu/drm/drm_fb_helper.c
+++ b/drivers/gpu/drm/drm_fb_helper.c
-@@ -2099,6 +2099,10 @@ struct drm_display_mode *drm_pick_cmdlin
+@@ -2104,6 +2104,10 @@ struct drm_display_mode *drm_pick_cmdlin
prefer_non_interlace = !cmdline_mode->interlace;
again:
list_for_each_entry(mode, &fb_helper_conn->connector->modes, head) {
diff --git a/target/linux/brcm2708/patches-4.19/950-0643-drm-modes-Allow-to-specify-rotation-and-reflection-o.patch b/target/linux/brcm2708/patches-4.19/950-0643-drm-modes-Allow-to-specify-rotation-and-reflection-o.patch
index f9ba856c44..0b2a185441 100644
--- a/target/linux/brcm2708/patches-4.19/950-0643-drm-modes-Allow-to-specify-rotation-and-reflection-o.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0643-drm-modes-Allow-to-specify-rotation-and-reflection-o.patch
@@ -52,7 +52,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/777da16e42db757c1f5b414b5ca3
What is the VESA(TM) Coordinated Video Timings (CVT)?
--- a/drivers/gpu/drm/drm_fb_helper.c
+++ b/drivers/gpu/drm/drm_fb_helper.c
-@@ -2464,6 +2464,7 @@ static void drm_setup_crtc_rotation(stru
+@@ -2469,6 +2469,7 @@ static void drm_setup_crtc_rotation(stru
struct drm_connector *connector)
{
struct drm_plane *plane = fb_crtc->mode_set.crtc->primary;
@@ -60,7 +60,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/777da16e42db757c1f5b414b5ca3
uint64_t valid_mask = 0;
int i, rotation;
-@@ -2483,6 +2484,35 @@ static void drm_setup_crtc_rotation(stru
+@@ -2488,6 +2489,35 @@ static void drm_setup_crtc_rotation(stru
rotation = DRM_MODE_ROTATE_0;
}
diff --git a/target/linux/brcm2708/patches-4.19/950-0649-drm-modes-Don-t-apply-cmdline-s-rotation-if-it-wasn-.patch b/target/linux/brcm2708/patches-4.19/950-0649-drm-modes-Don-t-apply-cmdline-s-rotation-if-it-wasn-.patch
index 4cb0a543c0..b97d018799 100644
--- a/target/linux/brcm2708/patches-4.19/950-0649-drm-modes-Don-t-apply-cmdline-s-rotation-if-it-wasn-.patch
+++ b/target/linux/brcm2708/patches-4.19/950-0649-drm-modes-Don-t-apply-cmdline-s-rotation-if-it-wasn-.patch
@@ -23,7 +23,7 @@ Signed-off-by: Dave Stevenson <dave.stevenson@raspberrypi.org>
--- a/drivers/gpu/drm/drm_fb_helper.c
+++ b/drivers/gpu/drm/drm_fb_helper.c
-@@ -2497,7 +2497,7 @@ static void drm_setup_crtc_rotation(stru
+@@ -2502,7 +2502,7 @@ static void drm_setup_crtc_rotation(stru
* simple XOR between the two handle the addition nicely.
*/
cmdline = &connector->cmdline_mode;