aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--toolchain/glibc/common.mk17
-rw-r--r--toolchain/glibc/patches/200-add-dl-search-paths.patch2
2 files changed, 7 insertions, 12 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index 26e2376bfc..0ea166e77d 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -7,18 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=glibc
-PKG_VERSION:=2.24
-PKG_REVISION:=8c716c2
-PKG_MIRROR_HASH:=714d26c0daf6a8acf73fc8b6053349880c79f240f96ca57b00ab0ecbbead2b73
+PKG_VERSION:=2.25
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
-PKG_SOURCE_VERSION:=$(PKG_REVISION)
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REVISION)
-PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
-
-GLIBC_PATH:=
+PKG_SOURCE_URL:=@GNU/libc
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_HASH:=067bd9bb3390e79aa45911537d13c3721f1d9d3769931a30c2681bfee66f23a0
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_SOURCE_SUBDIR)
CUR_BUILD_DIR:=$(HOST_BUILD_DIR)-$(VARIANT)
@@ -77,7 +72,7 @@ endef
define Host/Configure
[ -f $(HOST_BUILD_DIR)/.autoconf ] || { \
- cd $(HOST_BUILD_DIR)/$(GLIBC_PATH); \
+ cd $(HOST_BUILD_DIR)/; \
autoconf --force && \
touch $(HOST_BUILD_DIR)/.autoconf; \
}
diff --git a/toolchain/glibc/patches/200-add-dl-search-paths.patch b/toolchain/glibc/patches/200-add-dl-search-paths.patch
index d65a0bcdd0..8f720cb9fd 100644
--- a/toolchain/glibc/patches/200-add-dl-search-paths.patch
+++ b/toolchain/glibc/patches/200-add-dl-search-paths.patch
@@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
--- a/Makeconfig
+++ b/Makeconfig
-@@ -526,6 +526,9 @@ else
+@@ -571,6 +571,9 @@ else
default-rpath = $(libdir)
endif