aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/x86-2.6/image/grub/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/x86-2.6/image/grub/Makefile b/target/linux/x86-2.6/image/grub/Makefile
index e30443e18c..365b327622 100644
--- a/target/linux/x86-2.6/image/grub/Makefile
+++ b/target/linux/x86-2.6/image/grub/Makefile
@@ -43,6 +43,7 @@ ifeq ($(HOST_ARCH),x86_64)
--mandir=/usr/man \
--infodir=/usr/info \
$(DISABLE_NLS) \
+ --disable-auto-linux-mem-opt \
)
endef
else
@@ -62,12 +63,20 @@ else
--localstatedir=/var \
--mandir=/usr/man \
--infodir=/usr/info \
+ $(DISABLE_NLS) \
+ --disable-auto-linux-mem-opt \
)
endef
endif
+#
+# ./configure detects whether the host compiler supports
+# -fno-stack-protector but only sets STAGE2_CFLAGS accordingly
+#
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ GRUB_CFLAGS="\$$$$(STAGE2_CFLAGS)" \
+ STAGE1_CFLAGS="\$$$$(STAGE2_CFLAGS)"
endef
define Build/InstallDev