aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--openwrt/Config.in4
-rw-r--r--openwrt/Config.in.devel5
-rw-r--r--openwrt/Makefile9
-rw-r--r--openwrt/target/Config.in4
-rw-r--r--openwrt/toolchain/Config.in41
-rw-r--r--openwrt/toolchain/Config.in.devel56
6 files changed, 50 insertions, 69 deletions
diff --git a/openwrt/Config.in b/openwrt/Config.in
index bdc8703e68..cccdce9bbd 100644
--- a/openwrt/Config.in
+++ b/openwrt/Config.in
@@ -32,6 +32,9 @@ config BR2_armeb
# Unsupported architectures
if CONFIG_DEVEL
+config BR2_mips64
+ tristate
+ select BR2_BIG_ENDIAN
config BR2_arm
tristate
@@ -76,6 +79,7 @@ config BR2_ARCH
default "m68k" if BR2_m68k
default "mips" if BR2_mips
default "mipsel" if BR2_mipsel || !CONFIG_DEVEL
+ default "mips64" if BR2_mips64
default "powerpc" if BR2_powerpc
default "sh3" if BR2_sh3
default "sh3eb" if BR2_sh3eb
diff --git a/openwrt/Config.in.devel b/openwrt/Config.in.devel
index 8e382f6399..644633d328 100644
--- a/openwrt/Config.in.devel
+++ b/openwrt/Config.in.devel
@@ -27,6 +27,8 @@ config BR2_mipsel
# Unsupported architectures
if CONFIG_DEVEL
+config BR2_mips64
+ tristate
config BR2_arm
tristate
@@ -69,6 +71,7 @@ config BR2_ARCH
default "m68k" if BR2_m68k
default "mips" if BR2_mips
default "mipsel" if BR2_mipsel || !CONFIG_DEVEL
+ default "mips64" if BR2_mips64
default "powerpc" if BR2_powerpc
default "sh3" if BR2_sh3
default "sh3eb" if BR2_sh3eb
@@ -99,6 +102,6 @@ config BR2_JLEVEL
endmenu
-source "toolchain/Config.in.devel"
+source "toolchain/Config.in"
source "package/Config.in"
source "target/linux/Config.in"
diff --git a/openwrt/Makefile b/openwrt/Makefile
index abc9dfee27..2fdc7647d4 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -34,7 +34,7 @@ CONFIG_DEFCONFIG = .defconfig
CONFIG = package/config
noconfig_targets := menuconfig config oldconfig randconfig \
- defconfig allyesconfig allnoconfig release tags
+ defconfig allyesconfig allnoconfig tags
# Pull in the user's configuration file
ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
@@ -47,6 +47,7 @@ include $(TOPDIR)/rules.mk
all: world
.NOTPARALLEL:
+.PHONY: all world clean dirclean distclean image_clean target_clean source configtest
#############################################################
#
@@ -62,8 +63,6 @@ world: $(DL_DIR) $(BUILD_DIR) configtest
$(MAKE) toolchain/install target/compile package/compile root_clean package/install target/install package_index
@$(TRACE) Build complete.
-.PHONY: all world clean dirclean distclean image_clean target_clean source configtest
-
configtest:
-cp .config .config.test
-scripts/configtest.pl
@@ -177,7 +176,3 @@ defconfig: $(CONFIG)/conf
-./scripts/configtest.pl
endif # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
-
-.PHONY: dummy subdirs release distclean clean config oldconfig \
- menuconfig tags check test depend
-
diff --git a/openwrt/target/Config.in b/openwrt/target/Config.in
index fa3843b990..e91089201d 100644
--- a/openwrt/target/Config.in
+++ b/openwrt/target/Config.in
@@ -79,6 +79,10 @@ config BR2_LINUX_2_6_X86
if CONFIG_DEVEL
+config BR2_LINUX_2_6_MIPS64
+ bool "UNSUPPORTED mips64 platform"
+ select BR2_mips64
+
config BR2_LINUX_2_6_ARM
bool "UNSUPPORTED little-endian arm platform"
select BR2_arm
diff --git a/openwrt/toolchain/Config.in b/openwrt/toolchain/Config.in
index a6fb858353..79a991bb42 100644
--- a/openwrt/toolchain/Config.in
+++ b/openwrt/toolchain/Config.in
@@ -1,30 +1,61 @@
#
+menu "Toolchain Options"
+
source "toolchain/uClibc/Config.in"
source "toolchain/binutils/Config.in"
source "toolchain/gcc/Config.in"
if CONFIG_DEVEL
- comment "Common Toolchain Options"
+comment "Common Toolchain Options"
+endif
+if !CONFIG_DEVEL
+comment "Using defaults
endif
config BR2_ENABLE_MULTILIB
- bool
+ bool "Enable multilib support?" if CONFIG_DEVEL
default n
+ help
+ If you want multilib enabled, enable this...
config BR2_LARGEFILE
- bool
+ bool "Enable large file (files > 2 GB) support?" if CONFIG_DEVEL
depends on !BR2_cris
default y
+ help
+ Enable large file (files > 2 GB) support
config BR2_SOFT_FLOAT
- bool
+ bool "Use software floating point by default" if CONFIG_DEVEL
default n
depends on BR2_arm || BR2_mips || BR2_powerpc
+ help
+ If your target CPU does not have a Floating Point Unit (FPU) or a
+ kernel FPU emulator, but you still wish to support floating point
+ functions, then everything will need to be compiled with soft floating
+ point support (-msoft-float).
+
+ Most people will answer N.
config BR2_TARGET_OPTIMIZATION
- string
+ string "Target Optimizations" if CONFIG_DEVEL
default "-Os -pipe -march=i486 -funit-at-a-time" if BR2_i386
default "-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" if BR2_mipsel || BR2_mips
default "-Os -pipe -mcpu=xscale -funit-at-a-time" if BR2_armeb
default "-Os -pipe -funit-at-a-time"
+ help
+ Optimizations to use when building for the target host.
+
+# Might be worth experimenting with for gcc 3.4.x.
+#GCC_WITH_CPU:=
+#GCC_WITH_ARCH:=
+#GCC_WITH_TUNE:=
+
+#GCC_WITH_CPU:=--with-cpu=
+#GCC_WITH_ARCH:=--with-arch=
+#GCC_WITH_TUNE:=--with-tune=
+
+
+endmenu
+
diff --git a/openwrt/toolchain/Config.in.devel b/openwrt/toolchain/Config.in.devel
deleted file mode 100644
index d9223fbcd3..0000000000
--- a/openwrt/toolchain/Config.in.devel
+++ /dev/null
@@ -1,56 +0,0 @@
-#
-
-menu "Toolchain Options"
-
-source "toolchain/uClibc/Config.in"
-source "toolchain/binutils/Config.in"
-source "toolchain/gcc/Config.in"
-
-
-comment "Common Toolchain Options"
-
-config BR2_ENABLE_MULTILIB
- bool "Enable multilib support?"
- default n
- help
- If you want multilib enabled, enable this...
-
-config BR2_LARGEFILE
- bool "Enable large file (files > 2 GB) support?"
- depends on !BR2_cris
- default y
- help
- Enable large file (files > 2 GB) support
-
-config BR2_SOFT_FLOAT
- bool "Use software floating point by default"
- default n
- depends on BR2_arm || BR2_mips || BR2_powerpc
- help
- If your target CPU does not have a Floating Point Unit (FPU) or a
- kernel FPU emulator, but you still wish to support floating point
- functions, then everything will need to be compiled with soft floating
- point support (-msoft-float).
-
- Most people will answer N.
-
-config BR2_TARGET_OPTIMIZATION
- string "Target Optimizations"
- default "-Os -pipe -march=i486 -funit-at-a-time" if BR2_i386
- default "-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" if BR2_mipsel || BR2_mips
- default "-Os -pipe -funit-at-a-time"
- help
- Optimizations to use when building for the target host.
-
-# Might be worth experimenting with for gcc 3.4.x.
-#GCC_WITH_CPU:=
-#GCC_WITH_ARCH:=
-#GCC_WITH_TUNE:=
-
-#GCC_WITH_CPU:=--with-cpu=
-#GCC_WITH_ARCH:=--with-arch=
-#GCC_WITH_TUNE:=--with-tune=
-
-
-endmenu
-