aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/Makefile b/target/Makefile
index a3b15b2659..4885ab98d3 100644
--- a/target/Makefile
+++ b/target/Makefile
@@ -33,7 +33,7 @@ clean: linux-clean sdk-clean imagebuilder-clean image_clean
prereq: FORCE
$(MAKE) -C linux/$(BOARD)-$(KERNEL) prereq
- $(MAKE) -C $(IMAGE_DIR) prereq
+ [ \! -f $(IMAGE_DIR)/Makefile ] || $(MAKE) -C $(IMAGE_DIR) prereq
sdk_install: FORCE
$(MAKE) -C sdk install