aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/config/ltq-vdsl-app/Makefile2
-rw-r--r--package/network/config/ltq-vdsl-app/files/dsl_control7
2 files changed, 5 insertions, 4 deletions
diff --git a/package/network/config/ltq-vdsl-app/Makefile b/package/network/config/ltq-vdsl-app/Makefile
index 2e6faac42d..0968811984 100644
--- a/package/network/config/ltq-vdsl-app/Makefile
+++ b/package/network/config/ltq-vdsl-app/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ltq-vdsl-app
PKG_VERSION:=4.17.18.6
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_BASE_NAME:=dsl_cpe_control
PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@OPENWRT
diff --git a/package/network/config/ltq-vdsl-app/files/dsl_control b/package/network/config/ltq-vdsl-app/files/dsl_control
index 5089d7ac31..54b739e2cd 100644
--- a/package/network/config/ltq-vdsl-app/files/dsl_control
+++ b/package/network/config/ltq-vdsl-app/files/dsl_control
@@ -4,10 +4,11 @@
START=97
USE_PROCD=1
-extra_command "dslstat" "Get DSL status information"
-extra_command "lucistat" "Get status information in lua friendly format"
+dslstat() {
+ ubus call dsl metrics
+}
-. /lib/functions/lantiq_dsl.sh
+extra_command "dslstat" "Get DSL status information"
#
# ITU-T G.997.1 (06/2012) - Section 7.3.1.1.1 (xTU transmission system enabling (XTSE))