aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile14
-rw-r--r--include/toplevel.mk14
2 files changed, 14 insertions, 14 deletions
diff --git a/Makefile b/Makefile
index 2b08d30ffe..2499304c6a 100644
--- a/Makefile
+++ b/Makefile
@@ -86,20 +86,6 @@ prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
$(_SINGLE)$(SUBMAKE) -r package/index
-# update all feeds, re-create index files, install symlinks
-package/symlinks:
- $(SCRIPT_DIR)/feeds update -a
- $(SCRIPT_DIR)/feeds install -a
-
-# re-create index files, install symlinks
-package/symlinks-install:
- $(SCRIPT_DIR)/feeds update -i
- $(SCRIPT_DIR)/feeds install -a
-
-# remove all symlinks, don't touch ./feeds
-package/symlinks-clean:
- $(SCRIPT_DIR)/feeds uninstall -a
-
.PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean
endif
diff --git a/include/toplevel.mk b/include/toplevel.mk
index d8651d923b..bbeb7ebcef 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -193,6 +193,20 @@ else
endif
+# update all feeds, re-create index files, install symlinks
+package/symlinks:
+ ./scripts/feeds update -a
+ ./scripts/feeds install -a
+
+# re-create index files, install symlinks
+package/symlinks-install:
+ ./scripts/feeds update -i
+ ./scripts/feeds install -a
+
+# remove all symlinks, don't touch ./feeds
+package/symlinks-clean:
+ ./scripts/feeds uninstall -a
+
help:
cat README