aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/network/config/firewall/Makefile4
-rw-r--r--package/network/config/firewall4/Makefile2
2 files changed, 4 insertions, 2 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index 378a912f9d..815e33604c 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -9,7 +9,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/firewall3.git
@@ -29,6 +29,8 @@ define Package/firewall
CATEGORY:=Base system
TITLE:=OpenWrt C Firewall
DEPENDS:=+libubox +libubus +libuci +libip4tc +IPV6:libip6tc +libxtables +kmod-ipt-core +kmod-ipt-conntrack +IPV6:kmod-nf-conntrack6 +kmod-ipt-nat
+ PROVIDES:=uci-firewall
+ CONFLICTS:=firewall4
endef
define Package/firewall/description
diff --git a/package/network/config/firewall4/Makefile b/package/network/config/firewall4/Makefile
index c95a15a839..d7f8334dfc 100644
--- a/package/network/config/firewall4/Makefile
+++ b/package/network/config/firewall4/Makefile
@@ -26,7 +26,7 @@ define Package/firewall4
+kmod-nft-nat +kmod-nft-nat6 \
+nftables-json \
+ucode +ucode-mod-fs +ucode-mod-ubus +ucode-mod-uci
- CONFLICTS:=firewall
+ PROVIDES:=uci-firewall
endef
define Package/firewall4/description