aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/brcm47xx/Makefile2
-rw-r--r--target/linux/brcm47xx/patches-3.0/022-USB-Add-ehci-ssb-driver.patch6
-rw-r--r--target/linux/brcm47xx/patches-3.0/023-usb_ehci_ohci.patch4
-rw-r--r--target/linux/generic/patches-3.0/642-bridge_port_isolate.patch2
-rw-r--r--target/linux/generic/patches-3.0/811-pci_disable_usb_common_quirks.patch4
-rw-r--r--target/linux/generic/patches-3.0/950-vm_exports.patch2
-rw-r--r--target/linux/malta/Makefile2
-rw-r--r--target/linux/orion/Makefile2
-rw-r--r--target/linux/ppc40x/Makefile2
-rw-r--r--target/linux/ppc44x/Makefile2
-rw-r--r--target/linux/realview/Makefile2
12 files changed, 17 insertions, 17 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 4fd3207a7d..6161d122fd 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -29,8 +29,8 @@ endif
ifeq ($(LINUX_VERSION),2.6.39.2)
LINUX_KERNEL_MD5SUM:=51be93d92028658ec93f68b79a378b17
endif
-ifeq ($(LINUX_VERSION),3.0)
- LINUX_KERNEL_MD5SUM:=398e95866794def22b12dfbc15ce89c0
+ifeq ($(LINUX_VERSION),3.0.1)
+ LINUX_KERNEL_MD5SUM:=aed949984b878b7fb77ffe9cbee8ce0c
endif
# disable the md5sum check for unknown kernel versions
diff --git a/target/linux/brcm47xx/Makefile b/target/linux/brcm47xx/Makefile
index 969dfe2ce7..167d9e4ecb 100644
--- a/target/linux/brcm47xx/Makefile
+++ b/target/linux/brcm47xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb pcmcia
-LINUX_VERSION:=3.0
+LINUX_VERSION:=3.0.1
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
diff --git a/target/linux/brcm47xx/patches-3.0/022-USB-Add-ehci-ssb-driver.patch b/target/linux/brcm47xx/patches-3.0/022-USB-Add-ehci-ssb-driver.patch
index d236fcbbbe..bd51587543 100644
--- a/target/linux/brcm47xx/patches-3.0/022-USB-Add-ehci-ssb-driver.patch
+++ b/target/linux/brcm47xx/patches-3.0/022-USB-Add-ehci-ssb-driver.patch
@@ -22,7 +22,7 @@
depends on USB
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
-@@ -1286,9 +1286,14 @@ MODULE_LICENSE ("GPL");
+@@ -1284,9 +1284,14 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ehci_grlib_driver
#endif
@@ -38,7 +38,7 @@
#error "missing bus glue for ehci-hcd"
#endif
-@@ -1348,10 +1353,20 @@ static int __init ehci_hcd_init(void)
+@@ -1346,10 +1351,20 @@ static int __init ehci_hcd_init(void)
if (retval < 0)
goto clean4;
#endif
@@ -60,7 +60,7 @@
clean4:
#endif
#ifdef OF_PLATFORM_DRIVER
-@@ -1382,6 +1397,9 @@ module_init(ehci_hcd_init);
+@@ -1380,6 +1395,9 @@ module_init(ehci_hcd_init);
static void __exit ehci_hcd_cleanup(void)
{
diff --git a/target/linux/brcm47xx/patches-3.0/023-usb_ehci_ohci.patch b/target/linux/brcm47xx/patches-3.0/023-usb_ehci_ohci.patch
index a3ec2b70d0..ed444548be 100644
--- a/target/linux/brcm47xx/patches-3.0/023-usb_ehci_ohci.patch
+++ b/target/linux/brcm47xx/patches-3.0/023-usb_ehci_ohci.patch
@@ -152,7 +152,7 @@
+#endif
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
-@@ -1354,17 +1354,21 @@ static int __init ehci_hcd_init(void)
+@@ -1352,17 +1352,21 @@ static int __init ehci_hcd_init(void)
goto clean4;
#endif
@@ -174,7 +174,7 @@
#ifdef XILINX_OF_PLATFORM_DRIVER
platform_driver_unregister(&XILINX_OF_PLATFORM_DRIVER);
clean4:
-@@ -1397,9 +1401,11 @@ module_init(ehci_hcd_init);
+@@ -1395,9 +1399,11 @@ module_init(ehci_hcd_init);
static void __exit ehci_hcd_cleanup(void)
{
diff --git a/target/linux/generic/patches-3.0/642-bridge_port_isolate.patch b/target/linux/generic/patches-3.0/642-bridge_port_isolate.patch
index 1964e1893c..a1214c134b 100644
--- a/target/linux/generic/patches-3.0/642-bridge_port_isolate.patch
+++ b/target/linux/generic/patches-3.0/642-bridge_port_isolate.patch
@@ -1,6 +1,6 @@
--- a/net/bridge/br_private.h
+++ b/net/bridge/br_private.h
-@@ -133,6 +133,7 @@ struct net_bridge_port
+@@ -134,6 +134,7 @@ struct net_bridge_port
unsigned long flags;
#define BR_HAIRPIN_MODE 0x00000001
diff --git a/target/linux/generic/patches-3.0/811-pci_disable_usb_common_quirks.patch b/target/linux/generic/patches-3.0/811-pci_disable_usb_common_quirks.patch
index 7561c3b068..1a003ee3cc 100644
--- a/target/linux/generic/patches-3.0/811-pci_disable_usb_common_quirks.patch
+++ b/target/linux/generic/patches-3.0/811-pci_disable_usb_common_quirks.patch
@@ -1,7 +1,7 @@
--- a/drivers/usb/host/pci-quirks.c
+++ b/drivers/usb/host/pci-quirks.c
-@@ -427,6 +427,8 @@ reset_needed:
+@@ -429,6 +429,8 @@ reset_needed:
}
EXPORT_SYMBOL_GPL(uhci_check_and_reset_hc);
@@ -10,7 +10,7 @@
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
{
u16 cmd;
-@@ -841,3 +843,5 @@ static void __devinit quirk_usb_early_ha
+@@ -869,3 +871,5 @@ static void __devinit quirk_usb_early_ha
quirk_usb_handoff_xhci(pdev);
}
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
diff --git a/target/linux/generic/patches-3.0/950-vm_exports.patch b/target/linux/generic/patches-3.0/950-vm_exports.patch
index a37be04e17..e1b88a0bb1 100644
--- a/target/linux/generic/patches-3.0/950-vm_exports.patch
+++ b/target/linux/generic/patches-3.0/950-vm_exports.patch
@@ -79,7 +79,7 @@
/**
* zap_vma_ptes - remove ptes mapping the vma
-@@ -3015,6 +3016,7 @@ static inline int check_stack_guard_page
+@@ -3071,6 +3072,7 @@ static inline int check_stack_guard_page
}
return 0;
}
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
index 4fbdf49d11..8f64714f30 100644
--- a/target/linux/malta/Makefile
+++ b/target/linux/malta/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.0
+LINUX_VERSION:=3.0.1
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/orion/Makefile b/target/linux/orion/Makefile
index 49e9ecb347..a8201f57ea 100644
--- a/target/linux/orion/Makefile
+++ b/target/linux/orion/Makefile
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.0
+LINUX_VERSION:=3.0.1
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index 59db6ef45a..ffd1b4489a 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.0
+LINUX_VERSION:=3.0.1
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
index 95f1ee631c..8f65693dba 100644
--- a/target/linux/ppc44x/Makefile
+++ b/target/linux/ppc44x/Makefile
@@ -13,7 +13,7 @@ FEATURES:=squashfs
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.0
+LINUX_VERSION:=3.0.1
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
index 55122ca04e..e697ba62df 100644
--- a/target/linux/realview/Makefile
+++ b/target/linux/realview/Makefile
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.0
+LINUX_VERSION:=3.0.1
include $(INCLUDE_DIR)/target.mk