aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts13
-rw-r--r--target/linux/mvebu/image/cortexa9.mk4
2 files changed, 2 insertions, 15 deletions
diff --git a/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts b/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts
index ea392f9e41..e0c0cb55a0 100644
--- a/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts
+++ b/target/linux/mvebu/files/arch/arm/boot/dts/armada-370-buffalo-ls421de.dts
@@ -209,12 +209,6 @@
gpio = <&gpio0 9 GPIO_ACTIVE_HIGH>;
};
};
-
- /* FIXME: this driver needs to be aware of the LED2 eth phy use,
- which must be set to off state before shutting down the machine */
- restart_poweroff {
- compatible = "restart-poweroff";
- };
};
&eth1 {
@@ -243,13 +237,6 @@
ethphy0: ethernet-phy@0 { /* Marvell 88E1518 */
reg = <0>;
- /*
- * LED2 is used to inform, at restart time, if the power
- * switch was slided to the "off" position.
- * Page 0x3, Register 0x10, bits 8-11:
- * 0x800: LED2 off, power off the machine
- * 0x900: LED2 on, boot the machine
- */
marvell,reg-init = <0x3 0x10 0x1 0x1991>, /* LED function */
<0x3 0x11 0x1 0x4401>, /* LED polarity */
<0x3 0x12 0x1 0x4905>; /* LED timer */
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index 7c2069ed2f..824f142a8b 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -24,8 +24,8 @@ define Device/buffalo_ls421de
DEVICE_DTS := armada-370-buffalo-ls421de
DEVICE_PACKAGES := \
kmod-rtc-rs5c372a kmod-hwmon-gpiofan kmod-hwmon-drivetemp kmod-usb3 \
- kmod-md-raid0 kmod-md-raid1 kmod-md-mod kmod-fs-xfs mkf2fs e2fsprogs \
- partx-utils
+ kmod-linkstation-poweroff kmod-md-raid0 kmod-md-raid1 kmod-md-mod \
+ kmod-fs-xfs mkf2fs e2fsprogs partx-utils
endef
TARGET_DEVICES += buffalo_ls421de