aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds1
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network4
-rw-r--r--target/linux/ath79/dts/ar9342_ubnt_nanostation-m-xw.dts37
-rw-r--r--target/linux/ath79/image/generic-ubnt.mk6
4 files changed, 48 insertions, 0 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index 705ae3d407..0fa4bc73bb 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -149,6 +149,7 @@ tplink,tl-wr841-v11)
ubnt,bullet-m|\
ubnt,bullet-m-xw|\
ubnt,nano-m|\
+ubnt,nanostation-m-xw|\
ubnt,rocket-m)
ucidef_set_rssimon "wlan0" "200000" "1"
ucidef_set_led_rssi "rssilow" "RSSILOW" "ubnt:red:link1" "wlan0" "1" "100"
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index f1171695bd..9a7f2d6472 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -212,6 +212,10 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth1" "2:lan:3" "3:lan:2" "4:lan:1"
;;
+ ubnt,nanostation-m-xw)
+ ucidef_add_switch "switch0" \
+ "0@eth0" "5:lan" "1:wan"
+ ;;
ubnt,nanostation-ac|\
ubnt,unifiac-mesh-pro|\
ubnt,unifiac-pro)
diff --git a/target/linux/ath79/dts/ar9342_ubnt_nanostation-m-xw.dts b/target/linux/ath79/dts/ar9342_ubnt_nanostation-m-xw.dts
new file mode 100644
index 0000000000..6ac79b0c1e
--- /dev/null
+++ b/target/linux/ath79/dts/ar9342_ubnt_nanostation-m-xw.dts
@@ -0,0 +1,37 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9342_ubnt_xw.dtsi"
+
+/ {
+ compatible = "ubnt,nanostation-m-xw", "ubnt,xw", "qca,ar9342";
+ model = "Ubiquiti Nanostation M (XW)";
+};
+
+&mdio0 {
+ status = "okay";
+
+ phy4-mii-enable;
+ phy-mask = <0x23>;
+
+ phy4: ethernet-phy@0 {
+ reg = <0>;
+ phy-mode = "mii";
+ };
+};
+
+&eth0 {
+ status = "okay";
+
+ phy-mode = "mii";
+ phy-handle = <&phy4>;
+
+ gmac-config {
+ device = <&gmac>;
+ mii-gmac0 = <1>;
+ mii-gmac0-slave = <1>;
+ };
+};
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 681c14dfb6..4f0a6a500d 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -113,6 +113,12 @@ define Device/ubnt_nano-m
endef
TARGET_DEVICES += ubnt_nano-m
+define Device/ubnt_nanostation-m-xw
+ $(Device/ubnt-xw)
+ DEVICE_TITLE := Ubiquiti Nanostation M (XW)
+endef
+TARGET_DEVICES += ubnt_nanostation-m-xw
+
define Device/ubnt_lap-120
$(Device/ubnt-wa)
DEVICE_TITLE := Ubiquiti LiteAP ac (LAP-120)