aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/iio.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/iio.mk b/package/kernel/linux/modules/iio.mk
index a1410170db..d0c2c365ca 100644
--- a/package/kernel/linux/modules/iio.mk
+++ b/package/kernel/linux/modules/iio.mk
@@ -155,3 +155,21 @@ define KernelPackage/iio-htu21/description
endef
$(eval $(call KernelPackage,iio-htu21))
+
+
+define KernelPackage/iio-tsl4531
+ SUBMENU:=$(IIO_MENU)
+ DEPENDS:=+kmod-i2c-core +kmod-iio-core
+ TITLE:=TAOS TSL4531 ambient light sensor
+ KCONFIG:= CONFIG_TSL4531
+ FILES:=$(LINUX_DIR)/drivers/iio/light/tsl4531.ko
+ AUTOLOAD:=$(call AutoLoad,56,tsl4531)
+endef
+
+define KernelPackage/iio-tsl4531/description
+ Support for TAOS TSL4531x family of ambient light sensors
+ connected via I2C. Following models are usable:
+ TSL45311, TSL45313, TSL45315, TSL45317.
+endef
+
+$(eval $(call KernelPackage,iio-tsl4531))