aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/toplevel.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 658eb4ce47..3f5a750030 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -104,6 +104,9 @@ scripts/config/mconf:
$(eval $(call rdep,scripts/config,scripts/config/mconf))
+scripts/config/qconf:
+ @$(_SINGLE)$(SUBMAKE) -s -C scripts/config qconf CC="$(HOSTCC_WRAPPER)"
+
scripts/config/conf:
@$(_SINGLE)$(SUBMAKE) -s -C scripts/config conf CC="$(HOSTCC_WRAPPER)"
@@ -136,6 +139,12 @@ menuconfig: scripts/config/mconf prepare-tmpinfo FORCE
[ -L .config ] && export KCONFIG_OVERWRITECONFIG=1; \
$< Config.in
+xconfig: scripts/config/qconf prepare-tmpinfo FORCE
+ if [ \! -e .config -a -e $(HOME)/.openwrt/defconfig ]; then \
+ cp $(HOME)/.openwrt/defconfig .config; \
+ fi
+ $< Config.in
+
prepare_kernel_conf: .config FORCE
ifeq ($(wildcard staging_dir/host/bin/quilt),)