aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/block.mk24
1 files changed, 23 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 3bc607c12e..c486a433c2 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -239,7 +239,12 @@ define KernelPackage/dm
CONFIG_BLK_DEV_DM \
CONFIG_DM_CRYPT \
CONFIG_DM_MIRROR
- FILES:=$(LINUX_DIR)/drivers/md/dm-*.ko
+ FILES:= \
+ $(LINUX_DIR)/drivers/md/dm-mod.ko \
+ $(LINUX_DIR)/drivers/md/dm-crypt.ko \
+ $(LINUX_DIR)/drivers/md/dm-log.ko \
+ $(LINUX_DIR)/drivers/md/dm-mirror.ko \
+ $(LINUX_DIR)/drivers/md/dm-region-hash.ko
AUTOLOAD:=$(call AutoLoad,30,dm-mod dm-log dm-region-hash dm-mirror dm-crypt)
endef
@@ -249,6 +254,23 @@ endef
$(eval $(call KernelPackage,dm))
+define KernelPackage/dm-raid
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=LVM2 raid support
+ DEPENDS:=+kmod-dm +kmod-md-mod \
+ +kmod-md-raid0 +kmod-md-raid1 +kmod-md-raid10 +kmod-md-raid456
+ KCONFIG:= \
+ CONFIG_DM_RAID
+ FILES:=$(LINUX_DIR)/drivers/md/dm-raid.ko
+ AUTOLOAD:=$(call AutoLoad,31,dm-raid)
+endef
+
+define KernelPackage/dm-raid/description
+ Kernel module necessary for LVM2 raid support
+endef
+
+$(eval $(call KernelPackage,dm-raid))
+
define KernelPackage/md-mod
SUBMENU:=$(BLOCK_MENU)