aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/mwlwifi/Makefile2
-rw-r--r--package/kernel/mwlwifi/patches/001-vendor_command_policy.patch19
2 files changed, 20 insertions, 1 deletions
diff --git a/package/kernel/mwlwifi/Makefile b/package/kernel/mwlwifi/Makefile
index 642d800836..aa8eea0450 100644
--- a/package/kernel/mwlwifi/Makefile
+++ b/package/kernel/mwlwifi/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mwlwifi
-PKG_RELEASE=1
+PKG_RELEASE=2
PKG_LICENSE:=ISC
PKG_LICENSE_FILES:=
diff --git a/package/kernel/mwlwifi/patches/001-vendor_command_policy.patch b/package/kernel/mwlwifi/patches/001-vendor_command_policy.patch
new file mode 100644
index 0000000000..1f06d55fc8
--- /dev/null
+++ b/package/kernel/mwlwifi/patches/001-vendor_command_policy.patch
@@ -0,0 +1,19 @@
+mac80211 from kernel 5.3 and later checks the new policy attribute.
+
+--- a/vendor_cmd.c
++++ b/vendor_cmd.c
+@@ -92,12 +92,14 @@ static const struct wiphy_vendor_command
+ .subcmd = MWL_VENDOR_CMD_SET_BF_TYPE},
+ .flags = WIPHY_VENDOR_CMD_NEED_NETDEV,
+ .doit = mwl_vendor_cmd_set_bf_type,
++ .policy = mwl_vendor_attr_policy,
+ },
+ {
+ .info = { .vendor_id = MRVL_OUI,
+ .subcmd = MWL_VENDOR_CMD_GET_BF_TYPE},
+ .flags = WIPHY_VENDOR_CMD_NEED_NETDEV,
+ .doit = mwl_vendor_cmd_get_bf_type,
++ .policy = mwl_vendor_attr_policy,
+ }
+ };
+