aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBoris Krasnovskiy <boris.krasnovskiy@lairdtech.com>2019-08-17 20:04:00 -0400
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-18 14:06:14 +0200
commit0c43219a3579a5b86e8b62d603f67872329657b0 (patch)
tree6163eb609ba5001d6fe0c3b36ae517893173f741
parent552c48ea4375420cf3db1f91038a3f4eca47361b (diff)
downloadupstream-0c43219a3579a5b86e8b62d603f67872329657b0.tar.gz
upstream-0c43219a3579a5b86e8b62d603f67872329657b0.tar.bz2
upstream-0c43219a3579a5b86e8b62d603f67872329657b0.zip
mwlwifi: Fix loading with backports v5.3
This adds a vendor command policy which is enforced since mac80211 from kernel 5.3 Fixes: 928e893a11db ("mac80211: Update to version 5.3-rc4-1") Signed-off-by: Boris Krasnovskiy <boris.krasnovskiy@lairdtech.com>
-rw-r--r--package/kernel/mwlwifi/Makefile2
-rw-r--r--package/kernel/mwlwifi/patches/001-vendor_command_policy.patch19
2 files changed, 20 insertions, 1 deletions
diff --git a/package/kernel/mwlwifi/Makefile b/package/kernel/mwlwifi/Makefile
index 642d800836..aa8eea0450 100644
--- a/package/kernel/mwlwifi/Makefile
+++ b/package/kernel/mwlwifi/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mwlwifi
-PKG_RELEASE=1
+PKG_RELEASE=2
PKG_LICENSE:=ISC
PKG_LICENSE_FILES:=
diff --git a/package/kernel/mwlwifi/patches/001-vendor_command_policy.patch b/package/kernel/mwlwifi/patches/001-vendor_command_policy.patch
new file mode 100644
index 0000000000..1f06d55fc8
--- /dev/null
+++ b/package/kernel/mwlwifi/patches/001-vendor_command_policy.patch
@@ -0,0 +1,19 @@
+mac80211 from kernel 5.3 and later checks the new policy attribute.
+
+--- a/vendor_cmd.c
++++ b/vendor_cmd.c
+@@ -92,12 +92,14 @@ static const struct wiphy_vendor_command
+ .subcmd = MWL_VENDOR_CMD_SET_BF_TYPE},
+ .flags = WIPHY_VENDOR_CMD_NEED_NETDEV,
+ .doit = mwl_vendor_cmd_set_bf_type,
++ .policy = mwl_vendor_attr_policy,
+ },
+ {
+ .info = { .vendor_id = MRVL_OUI,
+ .subcmd = MWL_VENDOR_CMD_GET_BF_TYPE},
+ .flags = WIPHY_VENDOR_CMD_NEED_NETDEV,
+ .doit = mwl_vendor_cmd_get_bf_type,
++ .policy = mwl_vendor_attr_policy,
+ }
+ };
+