aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--config/Config-kernel.in4
-rw-r--r--package/utils/mdadm/Makefile2
-rw-r--r--target/linux/generic/config-3.181
-rw-r--r--target/linux/generic/config-4.41
-rw-r--r--target/linux/generic/config-4.91
-rw-r--r--target/linux/generic/patches-3.18/903-debloat_direct_io.patch83
-rw-r--r--target/linux/generic/patches-4.4/903-debloat_direct_io.patch80
-rw-r--r--target/linux/generic/patches-4.9/903-debloat_direct_io.patch82
-rw-r--r--target/linux/oxnas/config-4.41
-rw-r--r--target/linux/sunxi/config-4.41
-rw-r--r--target/linux/zynq/config-4.41
11 files changed, 1 insertions, 256 deletions
diff --git a/config/Config-kernel.in b/config/Config-kernel.in
index a4c46f55ae..f65e3dab40 100644
--- a/config/Config-kernel.in
+++ b/config/Config-kernel.in
@@ -170,10 +170,6 @@ config KERNEL_AIO
bool "Compile the kernel with asynchronous IO support"
default n
-config KERNEL_DIRECT_IO
- bool "Compile the kernel with direct IO support"
- default n
-
config KERNEL_FHANDLE
bool "Compile the kernel with support for fhandle syscalls"
default n
diff --git a/package/utils/mdadm/Makefile b/package/utils/mdadm/Makefile
index 8ebc02cfa5..c25f34e511 100644
--- a/package/utils/mdadm/Makefile
+++ b/package/utils/mdadm/Makefile
@@ -27,7 +27,7 @@ define Package/mdadm
SUBMENU:=Disc
TITLE:=A tool for managing Soft RAID under Linux
URL:=http://www.kernel.org/pub/linux/utils/raid/mdadm/
- DEPENDS:=+@KERNEL_DIRECT_IO +libpthread +kmod-md-mod +kmod-md-raid0 +kmod-md-raid10 +kmod-md-raid1
+ DEPENDS:=+libpthread +kmod-md-mod +kmod-md-raid0 +kmod-md-raid10 +kmod-md-raid1
endef
define Package/mdadm/description
diff --git a/target/linux/generic/config-3.18 b/target/linux/generic/config-3.18
index ca9773441e..f434d56e6e 100644
--- a/target/linux/generic/config-3.18
+++ b/target/linux/generic/config-3.18
@@ -881,7 +881,6 @@ CONFIG_DEVPORT=y
# CONFIG_DGNC is not set
# CONFIG_DGRP is not set
# CONFIG_DHT11 is not set
-# CONFIG_DIRECT_IO is not set
CONFIG_DISABLE_DEV_COREDUMP=y
# CONFIG_DISCONTIGMEM_MANUAL is not set
# CONFIG_DISPLAY_CONNECTOR_ANALOG_TV is not set
diff --git a/target/linux/generic/config-4.4 b/target/linux/generic/config-4.4
index f57e265852..7587fec34e 100644
--- a/target/linux/generic/config-4.4
+++ b/target/linux/generic/config-4.4
@@ -926,7 +926,6 @@ CONFIG_DEVPORT=y
# CONFIG_DGAP is not set
# CONFIG_DGNC is not set
# CONFIG_DHT11 is not set
-# CONFIG_DIRECT_IO is not set
# CONFIG_DISCONTIGMEM_MANUAL is not set
# CONFIG_DISPLAY_CONNECTOR_ANALOG_TV is not set
# CONFIG_DISPLAY_CONNECTOR_DVI is not set
diff --git a/target/linux/generic/config-4.9 b/target/linux/generic/config-4.9
index 1b0bae62dd..731c3cd2ce 100644
--- a/target/linux/generic/config-4.9
+++ b/target/linux/generic/config-4.9
@@ -1021,7 +1021,6 @@ CONFIG_DEVPORT=y
# CONFIG_DGAP is not set
# CONFIG_DGNC is not set
# CONFIG_DHT11 is not set
-# CONFIG_DIRECT_IO is not set
# CONFIG_DISCONTIGMEM_MANUAL is not set
# CONFIG_DISPLAY_CONNECTOR_ANALOG_TV is not set
# CONFIG_DISPLAY_CONNECTOR_DVI is not set
diff --git a/target/linux/generic/patches-3.18/903-debloat_direct_io.patch b/target/linux/generic/patches-3.18/903-debloat_direct_io.patch
deleted file mode 100644
index 166bb5ab64..0000000000
--- a/target/linux/generic/patches-3.18/903-debloat_direct_io.patch
+++ /dev/null
@@ -1,83 +0,0 @@
---- a/fs/Kconfig
-+++ b/fs/Kconfig
-@@ -61,6 +61,11 @@ config FILE_LOCKING
- for filesystems like NFS and for the flock() system
- call. Disabling this option saves about 11k.
-
-+config DIRECT_IO
-+ bool "Enable O_DIRECT support" if EXPERT
-+ depends on BLOCK
-+ default y
-+
- source "fs/notify/Kconfig"
-
- source "fs/quota/Kconfig"
---- a/fs/Makefile
-+++ b/fs/Makefile
-@@ -14,7 +14,8 @@ obj-y := open.o read_write.o file_table.
- stack.o fs_struct.o statfs.o fs_pin.o
-
- ifeq ($(CONFIG_BLOCK),y)
--obj-y += buffer.o block_dev.o direct-io.o mpage.o
-+obj-y += buffer.o block_dev.o mpage.o
-+obj-$(CONFIG_DIRECT_IO) += direct-io.o
- else
- obj-y += no-block.o
- endif
---- a/include/linux/fs.h
-+++ b/include/linux/fs.h
-@@ -2529,12 +2529,25 @@ enum {
- DIO_ASYNC_EXTEND = 0x04,
- };
-
-+#ifdef CONFIG_DIRECT_IO
- void dio_end_io(struct bio *bio, int error);
-
- ssize_t __blockdev_direct_IO(int rw, struct kiocb *iocb, struct inode *inode,
- struct block_device *bdev, struct iov_iter *iter, loff_t offset,
- get_block_t get_block, dio_iodone_t end_io,
- dio_submit_t submit_io, int flags);
-+#else
-+static inline void dio_end_io(struct bio *bio, int error)
-+{
-+}
-+static inline ssize_t __blockdev_direct_IO(int rw, struct kiocb *iocb, struct inode *inode,
-+ struct block_device *bdev, struct iov_iter *iter, loff_t offset,
-+ get_block_t get_block, dio_iodone_t end_io,
-+ dio_submit_t submit_io, int flags)
-+{
-+ return -EOPNOTSUPP;
-+}
-+#endif
-
- static inline ssize_t blockdev_direct_IO(int rw, struct kiocb *iocb,
- struct inode *inode, struct iov_iter *iter, loff_t offset,
---- a/fs/fcntl.c
-+++ b/fs/fcntl.c
-@@ -52,8 +52,10 @@ static int setfl(int fd, struct file * f
- arg |= O_NONBLOCK;
-
- if (arg & O_DIRECT) {
-+#ifdef CONFIG_DIRECT_IO
- if (!filp->f_mapping || !filp->f_mapping->a_ops ||
- !filp->f_mapping->a_ops->direct_IO)
-+#endif
- return -EINVAL;
- }
-
---- a/fs/open.c
-+++ b/fs/open.c
-@@ -655,9 +655,12 @@ int open_check_o_direct(struct file *f)
- {
- /* NB: we're sure to have correct a_ops only after f_op->open */
- if (f->f_flags & O_DIRECT) {
-+#ifdef CONFIG_DIRECT_IO
- if (!f->f_mapping->a_ops ||
- ((!f->f_mapping->a_ops->direct_IO) &&
-- (!f->f_mapping->a_ops->get_xip_mem))) {
-+ (!f->f_mapping->a_ops->get_xip_mem)))
-+#endif
-+ {
- return -EINVAL;
- }
- }
diff --git a/target/linux/generic/patches-4.4/903-debloat_direct_io.patch b/target/linux/generic/patches-4.4/903-debloat_direct_io.patch
deleted file mode 100644
index 3ced09a2a5..0000000000
--- a/target/linux/generic/patches-4.4/903-debloat_direct_io.patch
+++ /dev/null
@@ -1,80 +0,0 @@
---- a/fs/Kconfig
-+++ b/fs/Kconfig
-@@ -73,6 +73,11 @@ config FILE_LOCKING
- for filesystems like NFS and for the flock() system
- call. Disabling this option saves about 11k.
-
-+config DIRECT_IO
-+ bool "Enable O_DIRECT support" if EXPERT
-+ depends on BLOCK
-+ default y
-+
- source "fs/notify/Kconfig"
-
- source "fs/quota/Kconfig"
---- a/fs/Makefile
-+++ b/fs/Makefile
-@@ -14,7 +14,8 @@ obj-y := open.o read_write.o file_table.
- stack.o fs_struct.o statfs.o fs_pin.o nsfs.o
-
- ifeq ($(CONFIG_BLOCK),y)
--obj-y += buffer.o block_dev.o direct-io.o mpage.o
-+obj-y += buffer.o block_dev.o mpage.o
-+obj-$(CONFIG_DIRECT_IO) += direct-io.o
- else
- obj-y += no-block.o
- endif
---- a/include/linux/fs.h
-+++ b/include/linux/fs.h
-@@ -2717,6 +2717,7 @@ enum {
- DIO_SKIP_DIO_COUNT = 0x08,
- };
-
-+#ifdef CONFIG_DIRECT_IO
- void dio_end_io(struct bio *bio, int error);
-
- ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
-@@ -2724,6 +2725,18 @@ ssize_t __blockdev_direct_IO(struct kioc
- loff_t offset, get_block_t get_block,
- dio_iodone_t end_io, dio_submit_t submit_io,
- int flags);
-+#else
-+static inline void dio_end_io(struct bio *bio, int error)
-+{
-+}
-+static inline ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
-+ struct block_device *bdev, struct iov_iter *iter, loff_t offset,
-+ get_block_t get_block, dio_iodone_t end_io,
-+ dio_submit_t submit_io, int flags)
-+{
-+ return -EOPNOTSUPP;
-+}
-+#endif
-
- static inline ssize_t blockdev_direct_IO(struct kiocb *iocb,
- struct inode *inode,
---- a/fs/fcntl.c
-+++ b/fs/fcntl.c
-@@ -52,8 +52,10 @@ static int setfl(int fd, struct file * f
- arg |= O_NONBLOCK;
-
- if (arg & O_DIRECT) {
-+#ifdef CONFIG_DIRECT_IO
- if (!filp->f_mapping || !filp->f_mapping->a_ops ||
- !filp->f_mapping->a_ops->direct_IO)
-+#endif
- return -EINVAL;
- }
-
---- a/fs/open.c
-+++ b/fs/open.c
-@@ -673,7 +673,9 @@ int open_check_o_direct(struct file *f)
- {
- /* NB: we're sure to have correct a_ops only after f_op->open */
- if (f->f_flags & O_DIRECT) {
-+#ifdef CONFIG_DIRECT_IO
- if (!f->f_mapping->a_ops || !f->f_mapping->a_ops->direct_IO)
-+#endif
- return -EINVAL;
- }
- return 0;
diff --git a/target/linux/generic/patches-4.9/903-debloat_direct_io.patch b/target/linux/generic/patches-4.9/903-debloat_direct_io.patch
deleted file mode 100644
index fb8709e5bd..0000000000
--- a/target/linux/generic/patches-4.9/903-debloat_direct_io.patch
+++ /dev/null
@@ -1,82 +0,0 @@
---- a/fs/Kconfig
-+++ b/fs/Kconfig
-@@ -97,6 +97,11 @@ config MANDATORY_FILE_LOCKING
-
- source "fs/crypto/Kconfig"
-
-+config DIRECT_IO
-+ bool "Enable O_DIRECT support" if EXPERT
-+ depends on BLOCK
-+ default y
-+
- source "fs/notify/Kconfig"
-
- source "fs/quota/Kconfig"
---- a/fs/Makefile
-+++ b/fs/Makefile
-@@ -14,7 +14,8 @@ obj-y := open.o read_write.o file_table.
- stack.o fs_struct.o statfs.o fs_pin.o nsfs.o
-
- ifeq ($(CONFIG_BLOCK),y)
--obj-y += buffer.o block_dev.o direct-io.o mpage.o
-+obj-y += buffer.o block_dev.o mpage.o
-+obj-$(CONFIG_DIRECT_IO) += direct-io.o
- else
- obj-y += no-block.o
- endif
---- a/include/linux/fs.h
-+++ b/include/linux/fs.h
-@@ -2852,6 +2852,7 @@ enum {
- DIO_SKIP_DIO_COUNT = 0x08,
- };
-
-+#ifdef CONFIG_DIRECT_IO
- void dio_end_io(struct bio *bio, int error);
-
- ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
-@@ -2859,6 +2860,20 @@ ssize_t __blockdev_direct_IO(struct kioc
- get_block_t get_block,
- dio_iodone_t end_io, dio_submit_t submit_io,
- int flags);
-+#else
-+static inline void dio_end_io(struct bio *bio, int error)
-+{
-+}
-+static inline
-+ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
-+ struct block_device *bdev, struct iov_iter *iter,
-+ get_block_t get_block,
-+ dio_iodone_t end_io, dio_submit_t submit_io,
-+ int flags)
-+{
-+ return -EOPNOTSUPP;
-+}
-+#endif
-
- static inline ssize_t blockdev_direct_IO(struct kiocb *iocb,
- struct inode *inode,
---- a/fs/fcntl.c
-+++ b/fs/fcntl.c
-@@ -53,8 +53,10 @@ static int setfl(int fd, struct file * f
-
- /* Pipe packetized mode is controlled by O_DIRECT flag */
- if (!S_ISFIFO(filp->f_inode->i_mode) && (arg & O_DIRECT)) {
-+#ifdef CONFIG_DIRECT_IO
- if (!filp->f_mapping || !filp->f_mapping->a_ops ||
- !filp->f_mapping->a_ops->direct_IO)
-+#endif
- return -EINVAL;
- }
-
---- a/fs/open.c
-+++ b/fs/open.c
-@@ -690,7 +690,9 @@ int open_check_o_direct(struct file *f)
- {
- /* NB: we're sure to have correct a_ops only after f_op->open */
- if (f->f_flags & O_DIRECT) {
-+#ifdef CONFIG_DIRECT_IO
- if (!f->f_mapping->a_ops || !f->f_mapping->a_ops->direct_IO)
-+#endif
- return -EINVAL;
- }
- return 0;
diff --git a/target/linux/oxnas/config-4.4 b/target/linux/oxnas/config-4.4
index f1d08a4314..77a775582b 100644
--- a/target/linux/oxnas/config-4.4
+++ b/target/linux/oxnas/config-4.4
@@ -98,7 +98,6 @@ CONFIG_DEBUG_LL_INCLUDE="debug/icedcc.S"
CONFIG_DEFAULT_HUNG_TASK_TIMEOUT=16
CONFIG_DEPRECATED_PARAM_STRUCT=y
CONFIG_DETECT_HUNG_TASK=y
-CONFIG_DIRECT_IO=y
CONFIG_DMADEVICES=y
CONFIG_DMA_CACHE_FIQ_BROADCAST=y
# CONFIG_DMA_CACHE_RWFO is not set
diff --git a/target/linux/sunxi/config-4.4 b/target/linux/sunxi/config-4.4
index 2253afa124..f64e966847 100644
--- a/target/linux/sunxi/config-4.4
+++ b/target/linux/sunxi/config-4.4
@@ -136,7 +136,6 @@ CONFIG_DEBUG_MEMORY_INIT=y
CONFIG_DEFAULT_CFQ=y
# CONFIG_DEFAULT_DEADLINE is not set
CONFIG_DEFAULT_IOSCHED="cfq"
-CONFIG_DIRECT_IO=y
CONFIG_DMADEVICES=y
CONFIG_DMA_ENGINE=y
CONFIG_DMA_OF=y
diff --git a/target/linux/zynq/config-4.4 b/target/linux/zynq/config-4.4
index 70d09a1a43..52080e2ee9 100644
--- a/target/linux/zynq/config-4.4
+++ b/target/linux/zynq/config-4.4
@@ -179,7 +179,6 @@ CONFIG_DEBUG_LL_INCLUDE="mach/debug-macro.S"
CONFIG_DEFAULT_CFQ=y
# CONFIG_DEFAULT_DEADLINE is not set
CONFIG_DEFAULT_IOSCHED="cfq"
-CONFIG_DIRECT_IO=y
CONFIG_DMADEVICES=y
CONFIG_DMA_CMA=y
CONFIG_DMA_ENGINE=y