aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--include/kernel-version.mk4
-rw-r--r--target/linux/generic/pending-4.9/170-MIPS-PCI-add-controllers-before-the-specified-head.patch2
-rw-r--r--target/linux/generic/pending-4.9/330-MIPS-kexec-Accept-command-line-parameters-from-users.patch2
-rw-r--r--target/linux/lantiq/patches-4.9/0001-MIPS-lantiq-add-pcie-driver.patch2
4 files changed, 5 insertions, 5 deletions
diff --git a/include/kernel-version.mk b/include/kernel-version.mk
index 74e5224561..22f279ef7b 100644
--- a/include/kernel-version.mk
+++ b/include/kernel-version.mk
@@ -2,10 +2,10 @@
LINUX_RELEASE?=1
-LINUX_VERSION-4.9 = .137
+LINUX_VERSION-4.9 = .138
LINUX_VERSION-4.14 = .81
-LINUX_KERNEL_HASH-4.9.137 = 6db2512a9094bf4c830124641d1275635600b052962a7db3556da18914ea2589
+LINUX_KERNEL_HASH-4.9.138 = 92301242601d50854b173a3fdec318480e24fc86f32102003a9ed7108fab21b7
LINUX_KERNEL_HASH-4.14.81 = 4b36dfd053844ef0617799d432eed67aa4795d3403216d6789288aa7a0e75bde
remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
diff --git a/target/linux/generic/pending-4.9/170-MIPS-PCI-add-controllers-before-the-specified-head.patch b/target/linux/generic/pending-4.9/170-MIPS-PCI-add-controllers-before-the-specified-head.patch
index 3eed80e714..33f28912a2 100644
--- a/target/linux/generic/pending-4.9/170-MIPS-PCI-add-controllers-before-the-specified-head.patch
+++ b/target/linux/generic/pending-4.9/170-MIPS-PCI-add-controllers-before-the-specified-head.patch
@@ -19,7 +19,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
--- a/arch/mips/pci/pci-legacy.c
+++ b/arch/mips/pci/pci-legacy.c
-@@ -190,7 +190,7 @@ void register_pci_controller(struct pci_
+@@ -194,7 +194,7 @@ void register_pci_controller(struct pci_
}
INIT_LIST_HEAD(&hose->list);
diff --git a/target/linux/generic/pending-4.9/330-MIPS-kexec-Accept-command-line-parameters-from-users.patch b/target/linux/generic/pending-4.9/330-MIPS-kexec-Accept-command-line-parameters-from-users.patch
index ff85a13fda..c7abd99b3b 100644
--- a/target/linux/generic/pending-4.9/330-MIPS-kexec-Accept-command-line-parameters-from-users.patch
+++ b/target/linux/generic/pending-4.9/330-MIPS-kexec-Accept-command-line-parameters-from-users.patch
@@ -181,7 +181,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
/*
* The generic kexec code builds a page list with physical
-@@ -99,15 +214,16 @@ machine_kexec(struct kimage *image)
+@@ -102,15 +217,16 @@ machine_kexec(struct kimage *image)
/*
* we do not want to be bothered.
*/
diff --git a/target/linux/lantiq/patches-4.9/0001-MIPS-lantiq-add-pcie-driver.patch b/target/linux/lantiq/patches-4.9/0001-MIPS-lantiq-add-pcie-driver.patch
index f4013f5e21..c78f6c6031 100644
--- a/target/linux/lantiq/patches-4.9/0001-MIPS-lantiq-add-pcie-driver.patch
+++ b/target/linux/lantiq/patches-4.9/0001-MIPS-lantiq-add-pcie-driver.patch
@@ -4143,7 +4143,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+
--- a/arch/mips/pci/pci-legacy.c
+++ b/arch/mips/pci/pci-legacy.c
-@@ -300,3 +300,30 @@ char *__init pcibios_setup(char *str)
+@@ -304,3 +304,30 @@ char *__init pcibios_setup(char *str)
return pcibios_plat_setup(str);
return str;
}