aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/modules/other.mk17
-rw-r--r--target/linux/kirkwood/config-3.31
2 files changed, 17 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 1bf1755d32..773a2bc193 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -731,6 +731,23 @@ endef
$(eval $(call KernelPackage,pwm-gpio))
+
+define KernelPackage/rtc-marvell
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Marvell SoC built-in RTC support
+ $(call AddDepends/rtc)
+ DEPENDS+=@TARGET_kirkwood||TARGET_orion
+ KCONFIG:=CONFIG_RTC_DRV_MV
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-mv.ko
+ AUTOLOAD:=$(call AutoLoad,60,rtc-mv)
+endef
+
+define KernelPackage/rtc-marvell/description
+ Kernel module for Marvell SoC built-in RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-marvell))
+
define KernelPackage/rtc-pcf8563
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF8563/Epson RTC8564 RTC support
diff --git a/target/linux/kirkwood/config-3.3 b/target/linux/kirkwood/config-3.3
index 44b8a0c58d..7dd154dddc 100644
--- a/target/linux/kirkwood/config-3.3
+++ b/target/linux/kirkwood/config-3.3
@@ -155,7 +155,6 @@ CONFIG_PHYLIB=y
CONFIG_PLAT_ORION=y
# CONFIG_PREEMPT_RCU is not set
CONFIG_RTC_CLASS=y
-CONFIG_RTC_DRV_MV=y
CONFIG_SCSI=y
# CONFIG_SCSI_MULTI_LUN is not set
CONFIG_SPLIT_PTLOCK_CPUS=999999