aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-01-20 20:54:58 -0800
committerPaul Spooren <mail@aparcar.org>2021-01-30 18:14:50 -1000
commitec0c6c11436d233c3e1f3c1b4461a46348a1a0c7 (patch)
treef52b04d9712cf3a47ca8b549a25b328c1a7ae25c /tools
parent7534c8a2e1050e480c5b8636deaaf00b7adcb650 (diff)
downloadupstream-ec0c6c11436d233c3e1f3c1b4461a46348a1a0c7.tar.gz
upstream-ec0c6c11436d233c3e1f3c1b4461a46348a1a0c7.tar.bz2
upstream-ec0c6c11436d233c3e1f3c1b4461a46348a1a0c7.zip
tools/zstd: compile with cmake
It's faster and more reliable. Removed ccache cmake build dependency as it's now implicit. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile3
-rw-r--r--tools/zstd/Makefile9
2 files changed, 9 insertions, 3 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 09fe340e6c..a2665dbc9a 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -72,6 +72,7 @@ $(curdir)/sdcc/compile := $(curdir)/bison/compile
$(curdir)/squashfs/compile := $(curdir)/lzma-old/compile
$(curdir)/squashfskit4/compile := $(curdir)/xz/compile $(curdir)/zlib/compile
$(curdir)/zlib/compile := $(curdir)/cmake/compile
+$(curdir)/zstd/compile := $(curdir)/cmake/compile
ifneq ($(HOST_OS),Linux)
$(curdir)/squashfskit4/compile += $(curdir)/coreutils/compile
@@ -81,7 +82,7 @@ endif
ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
$(foreach tool, $(filter-out xz zstd patch pkgconf libressl cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
tools-y += ccache
-$(curdir)/ccache/compile := $(curdir)/cmake/compile $(curdir)/zstd/compile
+$(curdir)/ccache/compile := $(curdir)/zstd/compile
endif
# in case there is no patch tool on the host we need to make patch tool a
diff --git a/tools/zstd/Makefile b/tools/zstd/Makefile
index 1107c0d92c..a0106f15f2 100644
--- a/tools/zstd/Makefile
+++ b/tools/zstd/Makefile
@@ -11,11 +11,16 @@ PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
PKG_CPE_ID:=cpe:/a:facebook:zstandard
+CMAKE_SOURCE_SUBDIR:=build/cmake
HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
-HOSTCC := $(HOSTCC_NOCACHE)
-HOST_MAKE_FLAGS = PREFIX=$(HOST_BUILD_PREFIX) HAVE_ZLIB=0 HAVE_LZMA=0 HAVE_LZ4=0
+CMAKE_HOST_OPTIONS += \
+ -DBUILD_TESTING=OFF \
+ -DCMAKE_C_COMPILER_LAUNCHER="" \
+ -DCMAKE_C_COMPILER=$(HOSTCC_NOCACHE) \
+ -DZSTD_LEGACY_SUPPORT=OFF
$(eval $(call HostBuild))