aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-08-30 15:28:27 +0200
committerJo-Philipp Wich <jo@mein.io>2019-09-03 10:44:21 +0200
commitd3f86c9cc3e465fbca51aaadbb274856831ba56c (patch)
tree6667aefc76ca1fec6a9eb4dc3b930fe3353ab3dd /tools
parentac418ddeccc1ee5ae55ff74260ec98815fac9c47 (diff)
downloadupstream-d3f86c9cc3e465fbca51aaadbb274856831ba56c.tar.gz
upstream-d3f86c9cc3e465fbca51aaadbb274856831ba56c.tar.bz2
upstream-d3f86c9cc3e465fbca51aaadbb274856831ba56c.zip
tools: libelf: install pkg-config file
Install the pkg-config definition for libelf in order to allow the kernel build process discover it later on. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'tools')
-rw-r--r--tools/libelf/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/libelf/Makefile b/tools/libelf/Makefile
index 31e2eaf0a8..9fec8308b5 100644
--- a/tools/libelf/Makefile
+++ b/tools/libelf/Makefile
@@ -37,15 +37,17 @@ define Host/Compile
endef
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include/libelf}
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib/pkgconfig,include/libelf}
$(CP) $(HOST_BUILD_DIR)/lib/{elf_repl.h,gelf.h,libelf.h,nlist.h,sys_elf.h} \
$(STAGING_DIR_HOST)/include/libelf/
$(CP) $(HOST_BUILD_DIR)/lib/libelf.a $(STAGING_DIR_HOST)/lib/
+ $(CP) $(HOST_BUILD_DIR)/libelf.pc $(STAGING_DIR_HOST)/lib/pkgconfig/
endef
define Host/Clean
rm -rf $(STAGING_DIR_HOST)/include/libelf
rm -f $(STAGING_DIR_HOST)/lib/libelf.a
+ rm -f $(STAGING_DIR_HOST)/lib/pkgconfig/libelf.pc
$(call Host/Clean/Default)
endef