aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-07-02 06:49:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-07-02 06:49:36 +0000
commitce6b3da88091c3b0d631c98604fe691b87760e26 (patch)
treef974a6ff03a469baf42047aec9e1f0450b8ce9f7 /tools
parentbcf4757508f03f7b3e0c5b3b2d15627dbacbd4bd (diff)
downloadupstream-ce6b3da88091c3b0d631c98604fe691b87760e26.tar.gz
upstream-ce6b3da88091c3b0d631c98604fe691b87760e26.tar.bz2
upstream-ce6b3da88091c3b0d631c98604fe691b87760e26.zip
move mkelfimage from tools/ to package/ as it needs a proper i386 toolchain - make the package hidden so that it is automatically built without having to be selected
SVN-Revision: 27345
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
-rw-r--r--tools/mkelfimage/Makefile23
-rw-r--r--tools/mkelfimage/patches/no-stack-protector.patch11
3 files changed, 1 insertions, 35 deletions
diff --git a/tools/Makefile b/tools/Makefile
index a49e0cf97e..80c2d11628 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -19,7 +19,7 @@ tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
-tools-$(CONFIG_TARGET_x86) += qemu mkelfimage
+tools-$(CONFIG_TARGET_x86) += qemu
ifneq ($(CONFIG_TARGET_ar71xx),)
tools-y += lzma-old squashfs
endif
diff --git a/tools/mkelfimage/Makefile b/tools/mkelfimage/Makefile
deleted file mode 100644
index 75cff88d93..0000000000
--- a/tools/mkelfimage/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=mkelfimage
-PKG_VERSION:=2.7
-
-PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
-PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/m/mkelfimage/
-PKG_MD5SUM:=e505cb87e9c0cdc44cf03d2c4ea8c74b
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
- $(INSTALL_BIN) $(HOST_BUILD_DIR)/objdir/sbin/mkelfImage $(STAGING_DIR_HOST)/bin
-endef
-
-$(eval $(call HostBuild))
diff --git a/tools/mkelfimage/patches/no-stack-protector.patch b/tools/mkelfimage/patches/no-stack-protector.patch
deleted file mode 100644
index 108583aedd..0000000000
--- a/tools/mkelfimage/patches/no-stack-protector.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- mkelfimage-2.7.old//Makefile 2006-03-28 02:44:59.000000000 +0300
-+++ mkelfimage-2.7/Makefile 2011-01-17 14:15:13.000000000 +0200
-@@ -14,7 +14,7 @@
- pkglibdir = $(libdir)/$(PACKAGE)
- pkgincludedir = $(includedir)/$(PACKAGE)
-
--CPPFLAGS=-DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(RELEASE_DATE)"' -I include
-+CPPFLAGS=-DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(RELEASE_DATE)"' -I include -fno-stack-protector
- HOST_CPPFLAGS=$(CPPFLAGS)
- I386_CPPFLAGS=$(CPPFLAGS) -I arch/i386/include
- IA64_CPPFLAGS=$(CPPFLAGS) -I arch/ia64/include