aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-09-28 04:55:46 +0200
committerAlexander Couzens <lynxis@fe80.eu>2017-11-17 02:24:35 +0100
commitc61a2395140d92cdd37d3d6ee43a765427e8e318 (patch)
tree4d177012095867327963ef7c18e60dbc273a4b17 /tools
parenta479c79818cb9fe3913128f94340aebdfb732111 (diff)
downloadupstream-c61a2395140d92cdd37d3d6ee43a765427e8e318.tar.gz
upstream-c61a2395140d92cdd37d3d6ee43a765427e8e318.tar.bz2
upstream-c61a2395140d92cdd37d3d6ee43a765427e8e318.zip
add PKG_CPE_ID ids to package and tools
CPE ids helps to tracks CVE in packages. https://cpe.mitre.org/specification/ Thanks to swalker for CPE to package mapping and keep tracking CVEs. Acked-by: Jo-Philipp Wich <jo@mein.io> Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'tools')
-rw-r--r--tools/automake/Makefile1
-rw-r--r--tools/cmake/Makefile1
-rw-r--r--tools/coreutils/Makefile1
-rw-r--r--tools/dosfstools/Makefile1
-rw-r--r--tools/e2fsprogs/Makefile1
-rw-r--r--tools/expat/Makefile1
-rw-r--r--tools/findutils/Makefile1
-rw-r--r--tools/flex/Makefile1
-rw-r--r--tools/libtool/Makefile1
-rw-r--r--tools/m4/Makefile1
-rw-r--r--tools/mpfr/Makefile1
-rw-r--r--tools/qemu/Makefile1
-rw-r--r--tools/squashfs/Makefile1
-rw-r--r--tools/squashfs4/Makefile1
-rw-r--r--tools/tar/Makefile1
15 files changed, 15 insertions, 0 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 2e618f9974..c016f1d76a 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=automake
+PKG_CPE_ID:=cpe:/a:gnu:automake
PKG_VERSION:=1.15.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/tools/cmake/Makefile b/tools/cmake/Makefile
index 2c7b53e5c4..22e5d3e858 100644
--- a/tools/cmake/Makefile
+++ b/tools/cmake/Makefile
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
PKG_VERSION:=3.9.3
+PKG_CPE_ID:=cpe:/a:kitware:cmake
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://cmake.org/files/v3.9/ \
diff --git a/tools/coreutils/Makefile b/tools/coreutils/Makefile
index c731eafda6..4109fd77b3 100644
--- a/tools/coreutils/Makefile
+++ b/tools/coreutils/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=coreutils
+PKG_CPE_ID:=cpe:/a:gnu:coreutils
PKG_VERSION:=8.27
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/tools/dosfstools/Makefile b/tools/dosfstools/Makefile
index 861dcbf1c7..e34ceaf32b 100644
--- a/tools/dosfstools/Makefile
+++ b/tools/dosfstools/Makefile
@@ -8,6 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dosfstools
+PKG_CPE_ID:=cpe:/a:dosfstools_project:dosfstools
PKG_VERSION:=4.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/tools/e2fsprogs/Makefile b/tools/e2fsprogs/Makefile
index 0c054b13ca..412291ce74 100644
--- a/tools/e2fsprogs/Makefile
+++ b/tools/e2fsprogs/Makefile
@@ -8,6 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=e2fsprogs
+PKG_CPE_ID:=cpe:/a:e2fsprogs_project:e2fsprogs
PKG_VERSION:=1.43.6
PKG_HASH:=c9b226234ee878a8d89951f3b155cec7416dd0ec09c932c855f1b1df8ad93402
PKG_RELEASE:=1
diff --git a/tools/expat/Makefile b/tools/expat/Makefile
index 74ecbeef94..fd4d2065a1 100644
--- a/tools/expat/Makefile
+++ b/tools/expat/Makefile
@@ -8,6 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=expat
+PKG_CPE_ID:=cpe:/a:libexpat:expat
PKG_VERSION:=2.2.4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/tools/findutils/Makefile b/tools/findutils/Makefile
index b07c53d9f6..c1c45eeaab 100644
--- a/tools/findutils/Makefile
+++ b/tools/findutils/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=findutils
+PKG_CPE_ID:=cpe:/a:gnu:findutils
PKG_VERSION:=4.6.0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
index 1398b1ae51..1eff81f345 100644
--- a/tools/flex/Makefile
+++ b/tools/flex/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=flex
+PKG_CPE_ID:=cpe:/a:flex_project:flex
PKG_VERSION:=2.6.4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
index 6526b28b1d..dd4a7f6380 100644
--- a/tools/libtool/Makefile
+++ b/tools/libtool/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libtool
+PKG_CPE_ID:=cpe:/a:gnu:libtool
PKG_VERSION:=2.4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/tools/m4/Makefile b/tools/m4/Makefile
index aa3c382f5b..a6d931b0fd 100644
--- a/tools/m4/Makefile
+++ b/tools/m4/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=m4
+PKG_CPE_ID:=cpe:/a:gnu:m4
PKG_VERSION:=1.4.18
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/tools/mpfr/Makefile b/tools/mpfr/Makefile
index 96e0188bc8..f3e337ada2 100644
--- a/tools/mpfr/Makefile
+++ b/tools/mpfr/Makefile
@@ -8,6 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mpfr
PKG_VERSION:=3.1.6
+PKG_CPE_ID:=cpe:/a:mpfr:gnu_mpfr
PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION) \
@GNU/mpfr
diff --git a/tools/qemu/Makefile b/tools/qemu/Makefile
index 3eac66f01e..d63ab3482e 100644
--- a/tools/qemu/Makefile
+++ b/tools/qemu/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qemu
+PKG_CPE_ID:=cpe:/a:qemu:qemu
PKG_VERSION:=0.14.1
PKG_RELEASE:=1
diff --git a/tools/squashfs/Makefile b/tools/squashfs/Makefile
index 87f6e8fd99..385cf69d9d 100644
--- a/tools/squashfs/Makefile
+++ b/tools/squashfs/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=squashfs
+PKG_CPE_ID:=cpe:/a:phillip_lougher:squashfs
PKG_VERSION:=3.0
PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tar.gz
diff --git a/tools/squashfs4/Makefile b/tools/squashfs4/Makefile
index e2c9fc91cc..e9e2b7ca9a 100644
--- a/tools/squashfs4/Makefile
+++ b/tools/squashfs4/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=squashfs4
+PKG_CPE_ID:=cpe:/a:phillip_lougher:squashfs
PKG_VERSION:=4.2
PKG_SOURCE:=squashfs$(PKG_VERSION).tar.gz
diff --git a/tools/tar/Makefile b/tools/tar/Makefile
index 5cb695f8bd..10a4a89780 100644
--- a/tools/tar/Makefile
+++ b/tools/tar/Makefile
@@ -7,6 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=tar
+PKG_CPE_ID:=cpe:/a:gnu:tar
PKG_VERSION:=1.29
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2