aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-16 23:33:55 -0800
committerPetr Štetiar <ynezz@true.cz>2020-12-22 18:59:10 +0100
commitc0e6b785f00737a767113c728a6cf4f3838ef9a2 (patch)
treeffb6d4f313cc88e2ec45a98714d2bb1ba845002e /tools
parentb1952dc259ce3eb7ac6023c9e02d5adf2546efca (diff)
downloadupstream-c0e6b785f00737a767113c728a6cf4f3838ef9a2.tar.gz
upstream-c0e6b785f00737a767113c728a6cf4f3838ef9a2.tar.bz2
upstream-c0e6b785f00737a767113c728a6cf4f3838ef9a2.zip
tools/pkgconf: update to 1.7.3
Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools')
-rw-r--r--tools/pkgconf/Makefile4
-rw-r--r--tools/pkgconf/patches/0001-cli-remove-version-to-modversion-remapping.patch36
2 files changed, 2 insertions, 38 deletions
diff --git a/tools/pkgconf/Makefile b/tools/pkgconf/Makefile
index cefee1edf0..7d785aae39 100644
--- a/tools/pkgconf/Makefile
+++ b/tools/pkgconf/Makefile
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pkgconf
-PKG_VERSION:=1.6.3
+PKG_VERSION:=1.7.3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://distfiles.dereferenced.org/pkgconf
-PKG_HASH:=61f0b31b0d5ea0e862b454a80c170f57bad47879c0c42bd8de89200ff62ea210
+PKG_HASH:=b846aea51cf696c3392a0ae58bef93e2e72f8e7073ca6ad1ed8b01c85871f9c0
HOST_BUILD_PARALLEL:=1
diff --git a/tools/pkgconf/patches/0001-cli-remove-version-to-modversion-remapping.patch b/tools/pkgconf/patches/0001-cli-remove-version-to-modversion-remapping.patch
deleted file mode 100644
index b2c538d24e..0000000000
--- a/tools/pkgconf/patches/0001-cli-remove-version-to-modversion-remapping.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 62bbd3b664d4b03011a4b382ed20353a91c30406 Mon Sep 17 00:00:00 2001
-From: Ariadne Conill <ariadne@dereferenced.org>
-Date: Tue, 21 Jan 2020 10:32:36 -0600
-Subject: [PATCH] cli: remove --version to --modversion remapping
-
-This has been a source of frequent complaints, so we drop it.
-Resolves: https://todo.sr.ht/~kaniini/pkgconf/6
----
- cli/main.c | 14 ++------------
- 1 file changed, 2 insertions(+), 12 deletions(-)
-
-diff --git a/cli/main.c b/cli/main.c
-index 563ec8f0cfcd..fc698a4f9191 100644
---- a/cli/main.c
-+++ b/cli/main.c
-@@ -1005,18 +1005,8 @@ main(int argc, char *argv[])
-
- if ((want_flags & PKG_VERSION) == PKG_VERSION)
- {
-- if (argc > 2)
-- {
-- fprintf(stderr, "%s: --version specified with other options or module names, assuming --modversion.\n", argv[0]);
--
-- want_flags &= ~PKG_VERSION;
-- want_flags |= PKG_MODVERSION;
-- }
-- else
-- {
-- version();
-- return EXIT_SUCCESS;
-- }
-+ version();
-+ return EXIT_SUCCESS;
- }
-
- if ((want_flags & PKG_HELP) == PKG_HELP)