aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-05-17 10:33:46 +0000
committerJohn Crispin <john@openwrt.org>2011-05-17 10:33:46 +0000
commit9abcc013059c05da2f8ce918981f24bb92ea8014 (patch)
tree4bf7aea6958eb9f2707642e97557d0e94ce5ed16 /tools
parentc6a93676defb9113775e1ff3ba3d4c9f53640142 (diff)
downloadupstream-9abcc013059c05da2f8ce918981f24bb92ea8014.tar.gz
upstream-9abcc013059c05da2f8ce918981f24bb92ea8014.tar.bz2
upstream-9abcc013059c05da2f8ce918981f24bb92ea8014.zip
* adds mkelfimage
SVN-Revision: 26918
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
-rw-r--r--tools/mkelfimage/Makefile23
-rw-r--r--tools/mkelfimage/patches/no-stack-protector.patch11
3 files changed, 35 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 80c2d11628..a49e0cf97e 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -19,7 +19,7 @@ tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
tools-y += firmware-utils patch-cmdline quilt yaffs2 flock
tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake
tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
-tools-$(CONFIG_TARGET_x86) += qemu
+tools-$(CONFIG_TARGET_x86) += qemu mkelfimage
ifneq ($(CONFIG_TARGET_ar71xx),)
tools-y += lzma-old squashfs
endif
diff --git a/tools/mkelfimage/Makefile b/tools/mkelfimage/Makefile
new file mode 100644
index 0000000000..75cff88d93
--- /dev/null
+++ b/tools/mkelfimage/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mkelfimage
+PKG_VERSION:=2.7
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/m/mkelfimage/
+PKG_MD5SUM:=e505cb87e9c0cdc44cf03d2c4ea8c74b
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/objdir/sbin/mkelfImage $(STAGING_DIR_HOST)/bin
+endef
+
+$(eval $(call HostBuild))
diff --git a/tools/mkelfimage/patches/no-stack-protector.patch b/tools/mkelfimage/patches/no-stack-protector.patch
new file mode 100644
index 0000000000..108583aedd
--- /dev/null
+++ b/tools/mkelfimage/patches/no-stack-protector.patch
@@ -0,0 +1,11 @@
+--- mkelfimage-2.7.old//Makefile 2006-03-28 02:44:59.000000000 +0300
++++ mkelfimage-2.7/Makefile 2011-01-17 14:15:13.000000000 +0200
+@@ -14,7 +14,7 @@
+ pkglibdir = $(libdir)/$(PACKAGE)
+ pkgincludedir = $(includedir)/$(PACKAGE)
+
+-CPPFLAGS=-DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(RELEASE_DATE)"' -I include
++CPPFLAGS=-DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(RELEASE_DATE)"' -I include -fno-stack-protector
+ HOST_CPPFLAGS=$(CPPFLAGS)
+ I386_CPPFLAGS=$(CPPFLAGS) -I arch/i386/include
+ IA64_CPPFLAGS=$(CPPFLAGS) -I arch/ia64/include