aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorJoe Mullally <jwmullally@gmail.com>2020-09-12 19:46:28 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-04 15:44:05 +0200
commit7422c7a6fa2eb5f02f9bd7fa9d63ebe8514f88ff (patch)
tree7aa104556b6b8a504404fa239a1cdd1ee9e1532f /tools
parent4950071d307717b1d3eeb5e7c3fbdff3c601c574 (diff)
downloadupstream-7422c7a6fa2eb5f02f9bd7fa9d63ebe8514f88ff.tar.gz
upstream-7422c7a6fa2eb5f02f9bd7fa9d63ebe8514f88ff.tar.bz2
upstream-7422c7a6fa2eb5f02f9bd7fa9d63ebe8514f88ff.zip
ath79: add support for TP-Link TL-WPA8630P (EU) v2.1
This adds support for the TP-Link TL-WPA8630P (EU) in its v2.1 version. The only unique aspect for the firmware compared to v2 layout is the partition layout. Note that while the EU version has different partitioning for v2.0 and v2.1, the v2.1 (AU) is supported by the v2-int image. If you plan to use this device, make sure you have a look at the Wiki page to check whether the device is supported and which image needs to be taken. Specifications -------------- - QCA9563 750MHz, 2.4GHz WiFi - QCA9888 5GHz WiFi - 8MiB SPI Flash - 128MiB RAM - 3 GBit Ports (QCA8337) - PLC (QCA7550) Installation ------------ Installation is possible from the OEM web interface. Make sure to install the latest OEM firmware first, so that the PLC firmware is at the latest version. However, please also check the Wiki page for hints according to altered partitioning between OEM firmware revisions. Notes ----- The OEM firmware has 0x620000 to 0x680000 unassigned, so we leave this empty as well. It is complicated enough already ... Signed-off-by: Joe Mullally <jwmullally@gmail.com> [improve partitions, use v2 DTSI, add entry in 02_network, rewrite and extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'tools')
-rw-r--r--tools/firmware-utils/Makefile2
-rw-r--r--tools/firmware-utils/src/tplink-safeloader.c35
2 files changed, 36 insertions, 1 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 39c3503886..7f1754a347 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME := firmware-utils
-PKG_RELEASE := 3
+PKG_RELEASE := 4
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/kernel.mk
diff --git a/tools/firmware-utils/src/tplink-safeloader.c b/tools/firmware-utils/src/tplink-safeloader.c
index 82166a9ebb..eececeaf61 100644
--- a/tools/firmware-utils/src/tplink-safeloader.c
+++ b/tools/firmware-utils/src/tplink-safeloader.c
@@ -1513,6 +1513,41 @@ static struct device_info boards[] = {
.last_sysupgrade_partition = "file-system"
},
+ /** Firmware layout for the TL-WPA8630P v2.1 (EU)*/
+ {
+ .id = "TL-WPA8630P-V2.1-EU",
+ .vendor = "",
+ .support_list =
+ "SupportList:\n"
+ "{product_name:TL-WPA8630P,product_ver:2.1.0,special_id:45550000}\n",
+ .support_trail = '\x00',
+ .soft_ver = NULL,
+
+ .partitions = {
+ {"factory-uboot", 0x00000, 0x20000},
+ {"fs-uboot", 0x20000, 0x20000},
+ {"firmware", 0x40000, 0x5e0000},
+ {"extra-para", 0x680000, 0x01000},
+ {"product-info", 0x690000, 0x01000},
+ {"partition-table", 0x6a0000, 0x02000},
+ {"soft-version", 0x6b0000, 0x01000},
+ {"support-list", 0x6b1000, 0x01000},
+ {"profile", 0x6b2000, 0x08000},
+ {"user-config", 0x6c0000, 0x10000},
+ {"default-config", 0x6d0000, 0x10000},
+ {"default-nvm", 0x6e0000, 0xc0000},
+ {"default-pib", 0x7a0000, 0x40000},
+ {"default-mac", 0x7e0000, 0x00020},
+ {"pin", 0x7e0100, 0x00020},
+ {"device-id", 0x7e0200, 0x00030},
+ {"radio", 0x7f0000, 0x10000},
+ {NULL, 0, 0}
+ },
+
+ .first_sysupgrade_partition = "os-image",
+ .last_sysupgrade_partition = "file-system"
+ },
+
/** Firmware layout for the TL-WR1043 v5 */
{
.id = "TLWR1043NV5",