aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2021-01-13 08:11:00 +0100
committerRafał Miłecki <rafal@milecki.pl>2021-01-15 07:44:46 +0100
commit6e7ca70449f2fb10007918cdd4616c556ccc2ae1 (patch)
treeb2d64a7f2e28edc7c62eccfc89fa30340d6bb938 /tools
parent33646a51abcf15ff5c5363848287e1ed778b7467 (diff)
downloadupstream-6e7ca70449f2fb10007918cdd4616c556ccc2ae1.tar.gz
upstream-6e7ca70449f2fb10007918cdd4616c556ccc2ae1.tar.bz2
upstream-6e7ca70449f2fb10007918cdd4616c556ccc2ae1.zip
firmware-utils: bcm4908kernel: tool adding BCM4908 kernel header
BCM4908 CFE bootloader requires kernel to be prepended with a custom header. This simple tool implements support for such headers. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'tools')
-rw-r--r--tools/firmware-utils/Makefile1
-rw-r--r--tools/firmware-utils/src/bcm4908kernel.c127
2 files changed, 128 insertions, 0 deletions
diff --git a/tools/firmware-utils/Makefile b/tools/firmware-utils/Makefile
index 6074ecc608..a8c6ab4f65 100644
--- a/tools/firmware-utils/Makefile
+++ b/tools/firmware-utils/Makefile
@@ -27,6 +27,7 @@ define Host/Compile
$(call cc,add_header)
$(call cc,addpattern)
$(call cc,asustrx)
+ $(call cc,bcm4908kernel,-Wall)
$(call cc,buffalo-enc buffalo-lib,-Wall)
$(call cc,buffalo-tag buffalo-lib,-Wall)
$(call cc,buffalo-tftp buffalo-lib,-Wall)
diff --git a/tools/firmware-utils/src/bcm4908kernel.c b/tools/firmware-utils/src/bcm4908kernel.c
new file mode 100644
index 0000000000..fc5b2812ef
--- /dev/null
+++ b/tools/firmware-utils/src/bcm4908kernel.c
@@ -0,0 +1,127 @@
+// SPDX-License-Identifier: GPL-2.0-or-later
+/*
+ * Copyright (C) 2021 Rafał Miłecki <rafal@milecki.pl>
+ */
+
+#include <byteswap.h>
+#include <endian.h>
+#include <errno.h>
+#include <stdint.h>
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <unistd.h>
+
+#if !defined(__BYTE_ORDER)
+#error "Unknown byte order"
+#endif
+
+#if __BYTE_ORDER == __BIG_ENDIAN
+#define cpu_to_le32(x) bswap_32(x)
+#define le32_to_cpu(x) bswap_32(x)
+#elif __BYTE_ORDER == __LITTLE_ENDIAN
+#define cpu_to_le32(x) (x)
+#define le32_to_cpu(x) (x)
+#else
+#error "Unsupported endianness"
+#endif
+
+struct bcm4908kernel_header {
+ uint32_t unk1;
+ uint32_t unk2;
+ uint32_t length;
+ uint8_t magic[4];
+ uint32_t unused;
+};
+
+static void usage() {
+ printf("Usage:\n");
+ printf("\n");
+ printf("\t-i pathname\t\t\tinput kernel filepath\n");
+ printf("\t-o pathname\t\t\toutput kernel filepath\n");
+}
+
+int main(int argc, char **argv) {
+ struct bcm4908kernel_header header;
+ uint8_t buf[1024];
+ FILE *out = NULL;
+ FILE *in = NULL;
+ size_t length;
+ size_t bytes;
+ int err = 0;
+ char c;
+
+ if (argc >= 2 && !strcmp(argv[1], "-h")) {
+ usage();
+ return 0;
+ }
+
+ while ((c = getopt(argc, argv, "i:o:")) != -1) {
+ switch (c) {
+ case 'i':
+ in = fopen(optarg, "r");
+ break;
+ case 'o':
+ out = fopen(optarg, "w+");
+ break;
+ }
+ }
+
+ if (!in || !out) {
+ fprintf(stderr, "Failed to open input and/or output file\n");
+ usage();
+ return -EINVAL;
+ }
+
+ if (fread(&header, 1, sizeof(header), in) != sizeof(header)) {
+ fprintf(stderr, "Failed to read %zu bytes from input file\n", sizeof(header));
+ err = -EIO;
+ goto err_close;
+ }
+
+ if (!memcmp(header.magic, "BRCM", 4)) {
+ fprintf(stderr, "Input file already contains BCM4908 kernel header\n");
+ err = -EIO;
+ goto err_close;
+ }
+
+ err = fseek(out, sizeof(header), SEEK_SET);
+ if (err) {
+ err = -errno;
+ fprintf(stderr, "Failed to fseek(): %d\n", err);
+ goto err_close;
+ }
+
+ length = 0;
+ rewind(in);
+ while ((bytes = fread(buf, 1, sizeof(buf), in)) > 0) {
+ if (fwrite(buf, 1, bytes, out) != bytes) {
+ fprintf(stderr, "Failed to write %zu B to the output file\n", bytes);
+ err = -EIO;
+ goto err_close;
+ }
+ length += bytes;
+ }
+
+ header.unk1 = cpu_to_le32(0x00080000);
+ header.unk2 = cpu_to_le32(0x00080000);
+ header.length = cpu_to_le32(length);
+ header.magic[0] = 'B';
+ header.magic[1] = 'R';
+ header.magic[2] = 'C';
+ header.magic[3] = 'M';
+ header.unused = 0;
+
+ fseek(out, 0, SEEK_SET);
+
+ if (fwrite(&header, 1, sizeof(header), out) != sizeof(header)) {
+ fprintf(stderr, "Failed to write header to the output file\n");
+ err = -EIO;
+ goto err_close;
+ }
+
+err_close:
+ fclose(out);
+ fclose(in);
+ return err;
+}