aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2020-11-14 12:52:58 +0100
committerFelix Fietkau <nbd@nbd.name>2020-11-14 14:48:30 +0100
commit6c2ef55e6963d6ae36c4f9c85adaf7fe7aa1f369 (patch)
tree9cf5cc3fcb3d82632240cbb80eeb5bab821ab749 /tools
parenta99f88a1866ec082ab635db31a90de618840b165 (diff)
downloadupstream-6c2ef55e6963d6ae36c4f9c85adaf7fe7aa1f369.tar.gz
upstream-6c2ef55e6963d6ae36c4f9c85adaf7fe7aa1f369.tar.bz2
upstream-6c2ef55e6963d6ae36c4f9c85adaf7fe7aa1f369.zip
tools/bc: use autoreconf to fix build failure on macOS with recent Xcode versions
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
-rw-r--r--tools/bc/Makefile2
2 files changed, 3 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 65bec34c1b..4aa268de8f 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -41,7 +41,7 @@ tools-$(CONFIG_USE_SPARSE) += sparse
$(curdir)/autoconf/compile := $(curdir)/m4/compile
$(curdir)/automake/compile := $(curdir)/m4/compile $(curdir)/autoconf/compile $(curdir)/pkgconf/compile $(curdir)/xz/compile
$(curdir)/b43-tools/compile := $(curdir)/bison/compile
-$(curdir)/bc/compile := $(curdir)/bison/compile
+$(curdir)/bc/compile := $(curdir)/bison/compile $(curdir)/libtool/compile
$(curdir)/bison/compile := $(curdir)/flex/compile
$(curdir)/cbootimage/compile += $(curdir)/automake/compile
$(curdir)/cmake/compile += $(curdir)/libressl/compile
diff --git a/tools/bc/Makefile b/tools/bc/Makefile
index 3d505d6032..e5af713cf0 100644
--- a/tools/bc/Makefile
+++ b/tools/bc/Makefile
@@ -16,6 +16,8 @@ PKG_SOURCE_URL:=http://alpha.gnu.org/gnu/bc \
http://www.nic.funet.fi/pub/gnu/alpha/gnu/bc/
PKG_HASH:=7ee4abbcfac03d8a6e1a8a3440558a3d239d6b858585063e745c760957725ecc
+PKG_FIXUP := autoreconf
+
include $(INCLUDE_DIR)/host-build.mk
$(eval $(call HostBuild))