aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2009-03-22 14:37:47 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2009-03-22 14:37:47 +0000
commit66fddadb61ce210287ba8b753b8137b3f4f41401 (patch)
treec17e42c330f5a65b1a56d378e7cdb2876e531832 /tools
parentf960885d89d62e74d8045a90f9bb3b5d3634d8c0 (diff)
downloadupstream-66fddadb61ce210287ba8b753b8137b3f4f41401.tar.gz
upstream-66fddadb61ce210287ba8b753b8137b3f4f41401.tar.bz2
upstream-66fddadb61ce210287ba8b753b8137b3f4f41401.zip
[tools] add m4 (required for recent auto tools)
thanks to Olaf git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14966 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 5a7e8149ea..88755aeadd 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -9,12 +9,14 @@
curdir:=tools
# subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config autoconf automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) quilt $(if $(CONFIG_GCC_VERSION_4_3),gmp mpfr) yaffs2
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config m4 autoconf automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) quilt $(if $(CONFIG_GCC_VERSION_4_3),gmp mpfr) yaffs2
# builddir dependencies
$(curdir)/squashfs/compile := $(curdir)/lzma/install
$(curdir)/quilt/compile := $(curdir)/sed/install
$(curdir)/dtc/compile := $(curdir)/bison/install
+$(curdir)/autoconf/compile := $(curdir)/m4/install
+$(curdir)/automake/compile := $(curdir)/m4/install
# preparatory work
$(STAGING_DIR)/.prepared: $(TMP_DIR)/.build