aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-03 10:27:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-03 10:27:25 +0000
commit56885c545e05d783ffd0ce97c9132f8582080acd (patch)
tree1fb27cadfe17b964e32b293b245eb3a4b8dd0d09 /tools
parent096531f61ee62814b9ae7f078eb9ca191099f322 (diff)
downloadupstream-56885c545e05d783ffd0ce97c9132f8582080acd.tar.gz
upstream-56885c545e05d783ffd0ce97c9132f8582080acd.tar.bz2
upstream-56885c545e05d783ffd0ce97c9132f8582080acd.zip
fix recursive symlink issue
SVN-Revision: 12508
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/Makefile b/tools/Makefile
index f21b5a5820..e15f061a4d 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -38,7 +38,7 @@ $(STAGING_DIR_HOST)/bin/md5sum: $(STAGING_DIR)/.prepared
fi
$(STAGING_DIR_HOST)/bin/find: $(STAGING_DIR)/.prepared
- [ -x "$(FIND)" ] && ln -sf "$(FIND)" $@
+ [ -x "$(FIND)" -a "$(FIND)" != "$@" ] && ln -sf "$(FIND)" $@
$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,find md5sum)