aboutsummaryrefslogtreecommitdiffstats
path: root/tools
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-01-30 17:47:11 +0100
committerStijn Tintel <stijn@linux-ipv6.be>2017-01-30 18:37:51 +0100
commit456e1b648161c99c8d2379468842b61feac3be3a (patch)
treeb30d3bb972a6b55a93fb313c10d38262344923ae /tools
parentbdd1fad9e3af590867be15858e649cb55dcb6636 (diff)
downloadupstream-456e1b648161c99c8d2379468842b61feac3be3a.tar.gz
upstream-456e1b648161c99c8d2379468842b61feac3be3a.tar.bz2
upstream-456e1b648161c99c8d2379468842b61feac3be3a.zip
qemu: rename internal crypto/aes symbols
Qemu's local AES code defines symbols that conflict with LibreSSL/OpenSSL's libcrypto. Rename them to avoid build problems. See upstream commit c8d70e59738e672021926c7747af8ef9dea15c82. Fixes FS#444. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'tools')
-rw-r--r--tools/qemu/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/qemu/Makefile b/tools/qemu/Makefile
index 783d0f9fad..3eac66f01e 100644
--- a/tools/qemu/Makefile
+++ b/tools/qemu/Makefile
@@ -16,7 +16,13 @@ PKG_HASH:=33ceae3fbe516f2cbb151dc98d16c8ccfec74b1056674ad715e75a2f7fed45c3
include $(INCLUDE_DIR)/host-build.mk
-HOST_CFLAGS += -I$(STAGING_DIR_HOST)/include/e2fsprogs
+HOST_CFLAGS += \
+ -I$(STAGING_DIR_HOST)/include/e2fsprogs \
+ -DAES_cbc_encrypt=QEMU_AES_cbc_encrypt \
+ -DAES_decrypt=QEMU_AES_decrypt \
+ -DAES_encrypt=QEMU_AES_encrypt \
+ -DAES_set_decrypt_key=QEMU_AES_set_decrypt_key \
+ -DAES_set_encrypt_key=QEMU_AES_set_encrypt_key
HOST_CONFIGURE_VARS := \
CFLAGS="$(HOST_CFLAGS)" \