aboutsummaryrefslogtreecommitdiffstats
path: root/tools/zip/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2019-01-05 20:51:00 +0100
committerMathias Kresin <dev@kresin.me>2019-01-15 19:11:53 +0100
commitad8c2d6099a7da5192ee6e2c52a8303642271877 (patch)
tree29b3bc72d1e7448bc41636af088419eda1055339 /tools/zip/Makefile
parent4029788ff36a05a8731183269b675624269da84e (diff)
downloadupstream-ad8c2d6099a7da5192ee6e2c52a8303642271877.tar.gz
upstream-ad8c2d6099a7da5192ee6e2c52a8303642271877.tar.bz2
upstream-ad8c2d6099a7da5192ee6e2c52a8303642271877.zip
tools: add zip utility
One image requires a zip compressed image, so add the zip util found in the packages feed, and extend it with some useful debian patches. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'tools/zip/Makefile')
-rw-r--r--tools/zip/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/tools/zip/Makefile b/tools/zip/Makefile
new file mode 100644
index 0000000000..7dd81a1b8b
--- /dev/null
+++ b/tools/zip/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2007-2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=zip
+PKG_REV:=30
+PKG_VERSION:=3.0
+
+PKG_SOURCE:=$(PKG_NAME)$(PKG_REV).tar.gz
+PKG_SOURCE_URL:=@SF/infozip
+PKG_HASH:=f0e8bb1f9b7eb0b01285495a2699df3a4b766784c1765a8f1aeedf63c0806369
+
+PKG_LICENSE:=BSD-4-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-$(PKG_VERSION)/zip$(PKG_REV)
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ +$(HOST_MAKE_VARS) $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) -I. -f unix/Makefile zip
+endef
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/zip $(STAGING_DIR_HOST)/bin/
+endef
+
+$(eval $(call HostBuild))
+#$(eval $(call BuildPackage,zip))