aboutsummaryrefslogtreecommitdiffstats
path: root/tools/zip/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-09-28 01:23:56 -0700
committerChristian Marangi <ansuelsmth@gmail.com>2022-10-20 00:33:22 +0200
commita63805b25f99e609d575ee920baae269fb58794c (patch)
tree3d7090484571e2b300efdd658033378c250a485e /tools/zip/Makefile
parentf2ae4e2f8cf698f6fc6ae802dae86f50916f4286 (diff)
downloadupstream-a63805b25f99e609d575ee920baae269fb58794c.tar.gz
upstream-a63805b25f99e609d575ee920baae269fb58794c.tar.bz2
upstream-a63805b25f99e609d575ee920baae269fb58794c.zip
tools: add Host/Uninstall where possible
This cleans staging_dir when calling tool/x/clean. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/zip/Makefile')
-rw-r--r--tools/zip/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/zip/Makefile b/tools/zip/Makefile
index 7dd81a1b8b..6e83dafb40 100644
--- a/tools/zip/Makefile
+++ b/tools/zip/Makefile
@@ -32,5 +32,8 @@ define Host/Install
$(INSTALL_BIN) $(HOST_BUILD_DIR)/zip $(STAGING_DIR_HOST)/bin/
endef
+define Host/Clean
+ rm -rf $(STAGING_DIR_HOST)/bin/zip
+endef
+
$(eval $(call HostBuild))
-#$(eval $(call BuildPackage,zip))