aboutsummaryrefslogtreecommitdiffstats
path: root/tools/xz
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-03-27 00:50:16 -0700
committerChristian Lamparter <chunkeey@gmail.com>2019-04-06 19:14:06 +0200
commit46dc4e206d24a88bba103e28632b28ec9d9ec751 (patch)
tree5d956bd7b897d85df23ea7cbd0ceb788538ece6a /tools/xz
parent0eef05fb362469cb4adcf051d11b325adc8c2381 (diff)
downloadupstream-46dc4e206d24a88bba103e28632b28ec9d9ec751.tar.gz
upstream-46dc4e206d24a88bba103e28632b28ec9d9ec751.tar.bz2
upstream-46dc4e206d24a88bba103e28632b28ec9d9ec751.zip
tools/xz: Compile with PIC to fix linking errors
I made a similar change to this here: https://github.com/openwrt/packages/pull/8159 However, it turns out this did not fix the problem as the problem has to do with tools/xz and not the xz package. The error is the same and causes linking errors as can be seen above. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'tools/xz')
-rw-r--r--tools/xz/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/tools/xz/Makefile b/tools/xz/Makefile
index 5d574892bb..21029a74aa 100644
--- a/tools/xz/Makefile
+++ b/tools/xz/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -25,7 +25,8 @@ HOSTCXX := $(HOSTCXX_NOCACHE)
HOST_CONFIGURE_ARGS += \
--enable-static=yes \
--enable-shared=no \
- --disable-doc
+ --disable-doc \
+ --with-pic
define Host/Install
+$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"